Refresh files in the offline cache

Issue description:

I had an issue with mp3 files not playing because they were broken. I repaired / replaced the files on Kodi side. I synced the library afterwards with Symfonium. I am not sure whether the files were renewed in the offline cache (other files were re-added, but those had changed their path on Kodi side, so they were probably considered as “new”). The files still do not play in Synfonium.

Now I thought I could use the “remove from offline cache” function on album level to remove these files and afterwards re-add them, but I have the following issues with that:

  • After I hit “remove from offline cache” for the album, the files still do not play. They will not even play if I go through file mode and select them from Kodi directly. This makes me suspect that the broken files are still in the offline cache.
  • There is also no way to re-add those files to the offline cache. Should the function “remove from offline cache” change into “add to offline cache” after the files have been removed? In my case, it does not.
  • Can a single album even be removed from the offline cache if the containing genre (or in my case the whole library via auto-cache) has been added to the cache?


Sent via email - 20220402_164724
I tried to play and remove the files from cache a couple of times in the logs.

It should be possible I’ll check the logs later

As often the logs show the after the issue but not the issue :frowning:

Press cleanup in the manage offline files should fix this, but no idea how you reached it.

Cleanup doesn’t do anything. It shows the dialog, but then nothing happens. The files are not removed.

What files? You said there are already removed the cleanup just fix internal status when files are removed outside of Symfonium for example.
So it should properly mark what you removed as no more offline cached fixing the playback and properly showing the cache menu option and not the remove from cache one.

Well, I cannot say for sure if the files are still there (no way to find that out), but after cleanup the option still says “remove from offline cache” and playback still fails. So I assumed the broken files are still there in the offline cache.

Then I need logs when pressing that button and more details about what files / albums / songs

Logs from the cleanup and afterwards trying to play and “remove from cache” again: 20220403_115232

Album is “The Living Daylights” (soundtrack, John Barry, all files affected). I also repeatedly tried to remove the album “Out of Africa” from cache, to no avail.

Actually I think removing from offline cache simply does not work (for me). I just tried to remove a genre (containing only one artist though), and nothing happened. Logs: 20220403_120717

It does work :wink: One case would be that you have downloaded the items in the very very earliest alpha builds but I doubt.

No, it is not that long ago. A couple of versions for sure, but that was when you already launched beta.

I am thinking of resyncing my whole library because of the recent issues, but the cache download takes about 24hrs and needs me constantly waking up the phone…

If you check don’t kill my app you do not need to do anything to prevent the app from doing it’s job.

But no a full restart won’t fix whatever issue you have now.

Are you sure about Don’t kill my app? I had the impression that e.g. Samsung/Android disables WiFi some time after the screen is off, and the downloads stop then.

But if it won’t help then I won’t do it anyway. But what will help? :upside_down_face:

I’ll check what I can see in the logs you sent to see why the recovery does not work. You always reach impossible states, we need to find out how to prevent the issue, fixing the consequence is never a solution.

Can you show me precisely where you click to remove from offline cache? Logs are strange.

I sent new logs: 20220403_144738

Enabled logs, then went to home page, genres, soundtrack, albums, scrolled to the album (“The Living Daylights”), 3-dots, remove from offline cache, waited for 10 secs, then disabled logs.

Only thing I can imagine is that those files are in the download queue ? Can you check if it’s empty ?

Definitely empty. I checked now and also before, because I had a similar idea.

Well then I’ll need new logs when you get the next version I’ll add more stuff to try to figure out.