Every song on a playlist plays twice

Issue description:

When playing songs from a Subsonic server and streaming them to an UPnP player, I am having a consistent issue, like below:

I start by playing a whole album.
Music A starts playing. Once it finishes, Symfonium starts “playing” the following song B (as indicated on the UI, but with the duration of song A), while actually song A is the one playing (again).

Once Song A finishes playing for the second time, then finally, song B is played, and Synfonium correctly shows B.

Once B is done playing, it plays again, while Symfonium shows C as playing… On this iterative behavior like before.

This behavior is consistent until the end of the album.

When I play the same list locally on my device, that behavior is not there.

It felt it could be something similar to this issue: Track metadata is not updated on Bluetooth devices that support metadata when song ends - #15 by Nayviler


Upload description: joao_logs

Additional information:

On the UPnP side, I am using the upmpdcli and mpd

Reproduction steps:

Connect to UPnP player, start playing a playlist.

Media provider:




You probably need to update upmpdcli to the latest version, there’s problem with gapless just disable it in the renderer settings to workaround this.

I am just one minor version below, which does not seem to fix any issue related to that as per the release notes tbh.

I also tried to find any gapless settings on the /etc/upmpdcli.conf but nothing relates. Do you have any idea?

Thank you for the prompt support.

Well ask @medoc the upmpdcli author?

I know he fixed things a couple of month ago don’t know the version names.

1 Like

Just confirmed that indeed the problem is fixed on version Upmpdcli 1.8.12 libupnpp 0.26.6.

Unfortunately that version is still not available as debian packages. But after manually compiling and installing it, the issue is gone for good.

More tests are required it seems…

@joao, I use upmpdcli 1.8.10 and do not experience that issue, although occasionally I have the wrong song being shown in Symfonium while different song plays (I think that sometimes happens when I click on one song, then quickly on another one before the first song has even started playing). But I never have songs being played twice. Just wanted to let you know that it seems not to be a general issue.

What Tolriq meant with disabling gapless playback in the renderer settings is not on upmpdcli side, but within Symfonium: click on the cast icon, then on the settings icon next to your upmpdcli renderer:

And then on the gapless setting:

Thanks @splinter !!

I remember having seeing that settings somewhere, but I was trying to disable it from the app side for more than 1h. Went to every single menu-submenu, EXCEPT there where you pointed.

And indeed, that mitigates the problem, and I can listed to the playlists normally again.

Gapless should still work with upmpdcli, if you still have issues with the last version then please provide logs and if I may be able to help it’s author fix if there’s something broken.