App keeps crashing

I have Pixel 3 XL and Android 12 i bought this app and I like it very much but after a minute or two apps constntly keeps crash phone is getting very hot and phone is not responsive. I was trying to reinstall few times from Play Store and the link that You provided. I’ m connecting to my Emby server. App have turn off battery optimization turn off.

Please provide the mandatory logs as the template says.

Can you show the battery history on your devices as screenshot? I wonder if you have some optimization apps that could interfere with Symfonium triggering this.

Logs shows that the app is killed while in foreground service for low memory but does not show anything wrong showing that it would be doing something CPU intensive.

Just in case it’s a bug with the OS MP3 decoder can you try also to enable the option Prefer internal decoder in the Playback settings?

Can you share one of those mp3 in private so I can try to reproduce with same media on my Pixel 3a ?

Have you enabled full media offline cache or cached many many media in Symfonium ?

full media offline cache is disabled i changed to internal same issue i checked different mp3

Well Symfonium is not in the screenshot so why do you think Symfonium cause battery drain?

Since you have microG I assume you are not using the Google Android OS. What are you using? Are you sure there’s not other apps or settings on your device that might kill Symfonium?

It was running for 2 minutes and this is screenshot

I’m sure because if I kill Symfonium from process everything is back to normal

Again what ROM are you using?
From that screenshot Symfonium barely use as much as the launcher and remember that those are estimates, the OS report is the one to really trust as the only one to really have access to the data.

Does it happens when Symfonium is not playing? Does it happen when Symfonium cast to something and not play locally?

ROM is Stock orginal. When i cast to my shield this is the same. When Symfonium is open but not play anything everything is fine.

Do you have some firewall or something special on that device any other apps that monitor like accubatery?

This makes no sense as the app does nearly nothing when casting.

I don’t have any apps firewall that can błock. I have accubattery but i install it specially because i had problem with app

Maybe You can share with older app that I can try

And installed accu battery to have English texts.
Your screenshot actually shows that Symfonium is active and consume 5.7 mah so less than all your other apps.

So the issue is more complex than just consuming battery. All seems OK so there’s something else triggering this. Will be hard to find if I can’t repro on my old pixel 3a.

So updated and fully charged by Pixel 3a and no crash, no lags and everything normal. (And from Emby server too)

As you can see it even consume more battery on my tests as playing media not supported by the OS so require a little more CPU. The values are perfectly normal as in your previous screenshot.

So the real question is what really impact your phone, in the battery usage tab you’ll probably see more, I suspect maybe vanced MicroG or something else that tries to do stuff with the media session published.

What can help would be that you capture and send me a device bug report (see Capture and read bug reports  |  Android Developers) so I can what happens.

Send it privately it may contain sensitive informations!

BTW in battery usage you can see that on my P3a Symfonium consume less battery than AccuBattery

I delete everything fresh system and install only this one app, play music for two minute system become very unstable and app crashed . Maybe is something do with Android 12 what is Your version?

It’s updated to the last Android 12 patch from Google.

To investigate only the full bug report will have the necessary info.

I finally fixed it by downgrading my system to Android 11. Something is wrong with Android 12.

I cannot complain about Android 12. I upgraded a few days ago from Android 11, but no negative impact on Symfonium (or any other app I use)

Had symptoms like wosek was reporting on two different Pixel 4a5Gs with the latest Android 12. Tested it a couple weeks ago on my daily driver, and after a couple of songs Symfonium started silently crashing more and more frequently. The phone as a whole got more and more unusable until I performed a reboot. Figured it was some unusual interaction, so installed it on another phone that was recently factory reset (after installing the latest updates from Google) - same thing. Couple good songs, then increasing silent crashes until the phone is unusable to the point that the keyboard doesn’t even want to pop up.

I think I have a log file that I emailed myself from the second phone if that would be useful after some privacy sterilization. If needed, I can probably do a device bug report, but would need my trial reset. I can do limited testing on weekends, and maybe a very little bit on week nights. Both phones are Pixel 4a5G connecting to Emby https through a reverse proxy using non-standard ports. The Emby app works fine on both phones.

Can’t do much without the logs and the bug report and the trial ID :wink:

If you have the same issue as the OP, he fixed it by uninstalling the last updates of the Google app. The bug report shows a bug in the Bluetooth stack, but strangely I can’t reproduce on my p3a. And was not able to figure out a workaround to that.

Wondering if you have like a Verizon version that have modified OS ?