Track metadata is not updated on Bluetooth devices that support metadata when song ends

Issue description:

When connected to a Bluetooth device that displays the metadata of the currently playing song, metadata does not update when a new song starts (either by the previous song ending, or tapping the “next” button). The metadata is displayed correctly within the app itself, the issue is only with the metadata over Bluetooth. If I select a new song (by tapping on its name), the metadata is updated.

Steps to reproduce:

  • Connect to a device via Bluetooth that displays track metadata (a car, for instance).
  • Play a track in Symfonium, and either wait for the song to end, or press the skip button to go to the next song.
  • The metadata on the Bluetooth device is not updated with the correct information.

Logs: (40.8 KB)


Not really sure how I’d take a screenshot given the nature of the issue, but I took this photo of it occurring:

Additional information:

  • The issue does not occur every time I press the skip button or a song ends, however it is consistent enough to the point where it should be easily reproducible.
  • The metadata seems to correct itself if I pause the music.
  • I am using Symfonium 1.5.0 on a Google Pixel 6 running Android 12 (though I have experienced this issue on multiple devices, also running Android 12).
  • My media provider is Subsonic (the server is using Navidrome 0.47.5).
  • I’ve tried killing the app and restarting it, uninstalling and re-installing it, restarting my device, etc.
  • I do not experience this issue when using other music apps, such as Spotify.
  • The issue seems to have appeared with the latest update, this wasn’t occurring before that.

That’s very strange Symfonium does nothing special about BT.

Can you check your phone notification shade and the media session to see what data is visible there at that time ?

Also just in case it’s caused by the sometimes missing image can you try to join beta on Play Store and test with 1.6.0 beta 2 ?

The notification and media shade update with the app, no issues there as far as I can tell. As for the beta, Google Play reports that the beta program is full, so I’m unable to get the beta to test.

Since you say it was added in last version, let’s assume it’s caused by the small issue preventing image reload and one metadata push so it will be fixed in next release.
If not then I’ll try to find a way to repro.

@Nayviler 1.6.0 is published, please test again and confirm or not the change.

Unfortunately, the issue still persists on 1.6.0.

Well I’m out of home for nearly 2 weeks, but I guess it will be a fun debug session with random tests :frowning:
Can’t repro on my car (but it’s recent and also support Android Auto)

I believe I’m also experiencing this issue, although with a Wear OS 2 smartwatch. The song title is updated correctly, but the artist is never updated. That means that when starting a new media session, no artist is shown at all, and if a different artist was previously shown by another music app, that artist will continue to show when changing tracks in Synfonium.

Here are images of the issue:

(check the image description for more info, I couldn’t upload more than one image here on the forum because my account is new, so I had to share the album)

Device is a OnePlus 5 running Pixel Experience 12.1 (A12), connected to a Jellyfin backend.
Hope this helps :slight_smile:

Will add more logs about media session in next release but this makes no sense since the local OS media session is working.
Can you too confirm the Android notification always have the proper data ?

1 Like

From the looks of it, yes. And Musixmatch as well as Microsoft’s “Phone Link” are also picking up the correct artist :slight_smile: Just not the watch…

Here’s an APK of the next beta in case you are not in it, please try and report if it’s fixed.

app-beta-final.apk (6.1 MB)

Not fixed for me, unfortunately.

1 Like

Are you sure about * The issue seems to have appeared with the latest update, this wasn’t occurring before that. ?

I can’t see anything changed related to that and the fact that it only occurs on BT while the media session works on other devices is completely odd …

Maybe you had an OS update at the same time?

I do not see anything in src/com/android/bluetooth/audio_util/ - platform/packages/apps/Bluetooth - Git at Google that could cause this based on what I do.

Is your phone rooted or do you have a computer where you could use ADB to see if the OS logs something?

The other way to get the logs is via a bugreport but it contains a tons of private data so not sure you’d like to go that direction.

Actually I may have found something, please test this new APK

app-beta-final.apk (6.1 MB)

While the issue was always intermittent, I tried restarting my phone and my car multiple times and I can’t reproduce it now, so you might have just fixed it! I’ll continue to test over the next few days. If it happens again, I’ll get you those systems logs using ADB.

Also fixed for me! Great work :smiley: