Importing .xml playlists from jellyfin doesen't work

Issue description:

When trying to import a jellyfin playlist, which has been created on jellyfin, the playlist does not show up. I have tried the solutions from Jellyfin XML playlists unable to be imported which include making sure my account is allowed to view all libraries, and my account also has full managment permissions for jellyfin.

I also made these playlists with the same account.

Logs: (3.3 KB)


Jellyfin has playlists:

I would send a screenshot of symfonium, but it won’t let me.
EDIT: symfonium screen recording linked in comment.

Additional information:

I am using android 13 on a google pixel 4a, the newest version of symfonium from the google play store.

I am using jellyfin 10.8.9 running on docker on a mac mini (not an arm mac mini, it is a intel model)

Here is the issue I am having in symfonium:

 2023-08-25 07:52:55.182 T:JellyfinLogger 
<-- [736] {"Items":[],"TotalRecordCount":0,"StartIndex":0}

Your server does not return the playlists when asked for them. Check Jellyfin logs to be sure.

I fegured it out, turns out I was signed into a different account, and signing in to the same account which I made the playlists on fixed the problem, but I think there is still a bug. The account I was signed into on symfonium also had access to all libraries, so shouldn’t it still have worked?

There’s maybe a bug but on Jellyfin side.

I can’t force Jellyfin to return the data and I only have one account to request them.

Okay thats no big deal. Thank you so much for the help and responciveness