"Delete all" in download queue does not work with failed downloads

Issue description:

I had a number of failed downloads in the download queue. They failed because the Kodi library was not cleaned up properly and had entries whose files did not exist anymore (the downloads failed with a 404). I tried to remove the download entries in the list with the “delete all” button, but to no effect. Deleting every entry manually worked though. I logged both actions.


Sent via email: 20220701_180551

Due to the usual slow cleanup on your device :frowning: Will change order of things so that the cancellation is faster.

I suspected that already, but was surprised that the delete per track worked then.

Because there’s no cleanup in that case since it knows there’s no cancellation there’s no left over and the stop is clean.

Btw, I have another similar issue: two tracks are stuck in the download queue for a couple of days now. Cannot be resumed or deleted. When I look at the tracks, they are also shown as not in the cache (the rest of the album is). The problem probably occured due to lost wifi connection, but could not be resolved since. I did not try to add the tracks manually to the DL cache yet. Any cleanup should long be finished, and I had other tracks cached in the meantime.

Logs: 20220713_175859

@Tolriq, This might have slipped through during the summer holidays, but the issue mentioned in the last post still exists and was carried through several version upgrades. There are two entries in my download queue which never go away. I even removed and added the tracks to the cache manually in the meantime. Do you need any updated logs (doing what?)?

It’s not forgotten but it’s again one of your I managed to reach an impossible state at some point and the fixes prevent this but can’t really fix.

Anyway next version will have an hard clean of this on the advanced cleanup function.

Thanks! I also don’t know how I manage to always get to this point. Maybe I use the app too much :wink: