Codec info on play view?

Hi
I’ve set on the option to display codec info on play view, but it does not seem to work. Is my screen too small, or is it something else ? Even if I remove the rating line it’s still not displayed

Log: Dropbox - debug-20220702_120632.zip - Simplify your life


Did you try another play view? You can switch that to minimalist or clean, which removes several other things, but the codec info should show up.

Yep, it doesn’t show up in minimalist or clean view

Will look when back but it’s probably file format not natively supported by Android.

Try with simple mp3.

I’ve tried with mp3 and aac, but nothing shows up

Logs are strange. Does your username on Subsonic have some special / non ascii characters?

Nope, it’s the same username as here
What’s strange about the logs?

The error from Android is strange since all is ok.

Can you try from another phone? Or send me in private a test account ?

Works ok on my Navidrome setup.

I can’t test from another phone, but I’ll create you an account

Quickly tested and it works on your server with that account.

Can you test with the account you created for me in case it’s the account name or something strange on server side?
But I fear this is an Android/device specific issue and there’s not much I can do here. I currently have no plans to write my own parsers.

Ok i tried with the user I created for you, still not showing. Maybe my screen resolution is too small.

This is not resolution related, your phone gives an error when I ask it to extract the media Information.

Is this a custom ROM or something rooted with some exposed modules?

Nope, it’s the original OS (Samsung A5 2017), i don’t have any root access and never tried to have one.

Well I have no idea then :frowning:

All libraries for metadata extraction relies on files so can’t handle most of the needs.

I do have a similar problem with the display of the codecs. After enabling the setting, the codecs don’t appear instantly, but when switch it back of and on again, sometimes it does. The displayed codec also isn’t always right, sometimes it seems like when I switch from an MP3 256 track to an M4A 512 track, it keeps displaying the MP3 codec for the rest of the time.

Please provide logs. Pretty sure your Android fails at getting the codecs for MP4 but the previous one should not still be visible.

Link to folder with log file and screenshots: HiDrive

I first played an M4A file, and after that I played an MP3 file. As the screenshots tell you, when playing the MP3 file, the M4A codec is still shown.

When I started playing music, the codecs didn’t show up at all, so I had to re-enable the setting to make it work. I should be included within the log file.

Ok so no your issue is different it’s fixed in next release.

1 Like

That’s great to hear, thank you!