Can't get lyrics to show

Issue description:

I’m trying to get Symfonium to display lyrics for songs playing from my Jellyfin server (version 10.8.4).
From some of the other threads on this forum it seems like there are people who use Jellyfin and are able to see the lyrics.

What I’ve tried:

  1. Create four different tracks with different lyrics configuration:
    • “Muzzy - Endgame” has no lyrics at all
    • “JT Roach - Lazy Kisses” has a .lrc file containing synchronized lyrics next to the file on the server. The file has the exact same name, except for the different extension.
    • “Neoni - DARKSIDE” has synchronized lyrics which where embedded with MusicBee and no .lrc file
    • “PatrickReza - November” has unsynchronized lyrics, also embedded using MusicBee, no .lrc file.
  2. I’ve verified that MusicBee is showing lyrics for all tracks except “Muzzy - Endgame”, as expected. For synchronized lyrics, the current line is properly highlighted.
  3. After rescanning my music library in Jellyfin, I opened Symfonium, turned on Debug Mode, and started a Sync.
  4. I then played all for files in the same order as above. While the files where playing, I tapped the screen once, which highlights the floating buttons on the album cover (like, cast, etc.). (This sadly pauses the track and I couldn’t find a way to disable this.) I suspect that the lyrics button would show up as one of these floating buttons, as one person mentioned a button with contrast issues in the linked thread.
  5. I took screenshots of the Now Playing Screen and the song menu to show that I can’t see a lyrics button.
  6. During the third song, I chaged the Now Playing UI style from Minimalist to Default, in case lyrics are only shown for some of the styles. Still no lyrics button.

Logs:

Logs are here because it wouldn’t let me upload a < 5 MB file here directly, with the error message saying that the maximum is 19.7 MB…

Screenshots:

Muzzy - Endgame (no lyrics):


JT Roach - Lazy Kisses (.lrc file):


Neoni - DARKSIDE (embedded, synchronized):



PatrickReza - November (embedded, unsynchronized):


Additional information:

I am aware that just because MusicBee can show the lyrics that doesn’t mean Symfonium can too. MusicBee is accessing the file system, while Symfonium has to go through Jellyfin. I’m not demanding anything either.

It would be nice though to know which scenario is expected to work. In the changelog I couldn’t find specific information about that, and neither in the other threads.
Do files have to be downloaded offline? Are lyrics only supported when transcoding / direct playing? Is a certain Jellyfin version or plugin required?
Right now I’m just guessing and have no other ideas anymore :frowning:

A wiki entry for this would be much appreciated, if it isn’t too much work!
Thanks for your help.

Seems your files are offline cached see

For November the tags parser does not return the lyrics so I do not know how you added them but the tags does not looks valid. Maybe multiple tag version when not allowed ?

2022-08-26 15:53:36.868 Verbose/ExoPlayer:   Metadata [
2022-08-26 15:53:36.868 Verbose/ExoPlayer:     VC: encoder=Lavc59.18.100 libopus
2022-08-26 15:53:36.868 Verbose/ExoPlayer:     VC: title=November
2022-08-26 15:53:36.869 Verbose/ExoPlayer:     VC: artist=PatrickReza
2022-08-26 15:53:36.870 Verbose/ExoPlayer:     VC: album=November
2022-08-26 15:53:36.871 Verbose/ExoPlayer:     VC: ALBUMARTIST=PatrickReza
2022-08-26 15:53:36.871 Verbose/ExoPlayer:     VC: TRACKNUMBER=1
2022-08-26 15:53:36.872 Verbose/ExoPlayer:     VC: DISCNUMBER=1
2022-08-26 15:53:36.872 Verbose/ExoPlayer:     VC: genre=Electro
2022-08-26 15:53:36.873 Verbose/ExoPlayer:     VC: BARCODE=4260571120743
2022-08-26 15:53:36.873 Verbose/ExoPlayer:     VC: TSRC=DEWO71700094
2022-08-26 15:53:36.873 Verbose/ExoPlayer:     VC: TLEN=222000
2022-08-26 15:53:36.874 Verbose/ExoPlayer:     VC: publisher=CloudKid
2022-08-26 15:53:36.874 Verbose/ExoPlayer:     VC: date=2019-11-27
2022-08-26 15:53:36.875 Verbose/ExoPlayer:   ]

Ahh, that was the problem! I deleted all cached files and it immediately worked for Neoni - DARKSIDE! So I guess that means the requirements are:

  1. Files need to be streamed from Jellyfin and not cached
  2. Files need to have a lyrics tag with embedded synchronized lyrics.

For now I only have synchronized lyrics so I won’t be looking into why November didn’t work, but it’s good to know that the tag is invalid, thanks.

Thank you for helping me to figure this out, it was driving me insane :slight_smile:

Not at all :slight_smile:

If the lyrics are not in the tags then file needs to be streamed from Jellyfin and not offline cached for now until I rework some internals.

Else the lyrics needs to be properly embed in the music file synced or not

1 Like

Yeah it took me some more time to figure out the lyrics have to be inside the LYRICS tag and not in the USLT or SYLT tag, which seem to be normally used for that. At least these were the tag where all my existing music had the lyrics saved to. Maybe you could try to include the other two tags as well?

There was also a strange behavior were sometimes after an app restart the lyrics button would be shown for the songs and sometimes not, it wasn’t consistent. I’ll see if I can come up with a repro and then create a new post :slight_smile:

They are all supported but not all are allowed in all id3 versions.

Sounds like you embedding Id3 V1 and V2.X in the same file this is not really allowed / supported.

To use Id3 V2.3 or 2.4 you should remove the v1.