Transferring offline cache between devices

Issue description:

Due to an iffy network situation I’m trying to transfer the offline cache between two devices. I’m intending to swap phones. I have some intermittent 3G/4G at my disposal where I barely get any reception (I’ve attempted posting this multiple times now) as well as a local WiFi (no internet.)

I’ve tried ‘adb backup -apk’ but that just creates an empty backup. I’m assuming it’s because Symfonium is opting out of this behavior with allowBackup=false in the manifest.

So I figured I could just transfer the /sdcard/Android/data/ folder to the other device and have Symfoniun discover the files. The problem now lies in the file permissions/ownership. Due to running Android 13 on both devices the uid/gid of the folder contents are incorrect after moving them into the /sdcard/Android/data folder and therefore Symfonium isn’t able to access the files there.

Running chown on the files directly fails with ‘Operation not permitted.’

I tried running ‘adb shell run-as chown -R $correct-uid:$correct-gid /sdcard/Andr…’ but that fails with ‘package is not debuggable.’

Do you have any tips on how to solve this? Otherwise I’ll just have to wait until I get back to civilization in a few weeks.


(For posterity)
debug.log (54.6 KB)


Additional information:

I do not have a solution sorry, this is quite an edge case.

I think some file explorer apps have found a flaw in Android 13 to access private apps directory that would allow you copy the files. I think there was an article on XDA or AndroidPolice about that.

Yeah, no kidding. :slight_smile:

I’m experimenting with Total Commander and the hidden, built-in Files app, but so far neither seem to apply the correct permissions.

Android 13 continues to baffle me…