Tracks starting over during playback

Issue description:

This happens to me fairly regularly playing music from my Plex server: I’ll be listening to an album and some tracks will play for a bit and then start over from the beginning. It’s not consistent: it could be seconds or minutes into the track. It seems like when it happens it will happen several times for a single track, but then it might not happen at all for the next several tracks. Usually I’ll get frustrated and skip the track.

I finally was able to get lucky turning on debug logs and then reproducing the problem immediately. In the attached log file, the name of the track that restarted by itself mid-playback is “Pan and Broom” by Bright Eyes.

I hope the logs will be useful. Thanks!

Logs: (25.6 KB)

Hum unfortunately the logs does not contains everything :frowning: That’s strange :frowning: Would be nice if you could leave the debug mode on, restart the app to be sure then try to repro.

onPositionDiscontinuity: 5 [5]

I can see there’s an issue inside ExoPlayer but since 5 is Internal Reason it does not tell much and don’t know why the debugging of ExoPlayer was not enabled in those logs.

What’s also strange is that Plex says the app needs transcoding when it should not, can you send me that file in private so I can try to reproduce and fix the transcoding profiles too ?

I’ll have to try to repro it again when I’m not at work, but sure, here’s the file:

Bright Eyes - Down in the Weeds, Where the World Once Was - 06 - Pan and (4.3 MB)

Ok thanks was able to reproduce the transcoding issue.

Will be fixed for next release, that will probably also fix your issue trigged by Plex transcoding doing something strange, but logs would still be nice to really understand the cause and see if I can workaround that case too.

1 Like

Okay, I will turn on the logs the next time I’m listening to music and see if I can capture it again.

Okay, it happened again this morning (and also yesterday, but I’m not 100% sure if I had the debug turned on then or not).

I was listening to the album “Dragon New Warm Mountain I Believe in You” by “Big Thief.” The track was “Time Escaping” and it happened fairly early on in the track. (479.4 KB)

Ok thanks so yes it’s due to transcoding, so the next version will workaround this.

But to resume your plex server transcode (in this case not wanted but might be) to a non seekable format, for some reason the transcode is not fast enough or the network is a little slow at that moment, Exoplayer tries to buffer and seek to fix itself on the underrun but since the transcoding does not support seek it restart from the start :frowning:

I’ll have to see if I can do something about that.

Logs still shows “throttled”:true in the transcoding answer from Plex, so maybe there’s some settings on the server or something else running that impact transcoding ?

There could be a few reasons for it. Sometimes I’m streaming over VPN. And yes, I’ve also done some stuff with the transcoding configuration settings on Plex in the past to try to force direct play. I will wait for the next release and see how it works and possibly revisit my settings if needed. Thanks a lot!

I have a similar problem.
Info: using jellyfin, max bitrate set to 64kbps, transcoding flac to opus.

Songs won’t randomly start from the beginning during playback, but if song hasn’t cached/loaded and if I scrubb through it using progress bar it restarts. Even if I forward⏩ to next song and backwards⏮️ to the previous song it persists.

Solution: I have to restart playback in an already loaded/cached song for it to work, simply pressing play on the current playing song will work

Here’s the debug file, I can also provide screenrecord of said file (212.3 KB)

Open your own issues this have nothing to do with this issue …

Your issue is normal since you use playback cache the songs can’t be restarted at new transcoding point to seek since it would break the cache.

1 Like

My bad, I wasn’t sure if it was related or not.
Not sure if I got it, but if it’s normal, I’ll take it. Ain’t much of a bother anyway for this amazing app :smiley:
Ty for your work!