Subsonic (Navidrome) connection shows no media

My server shows no media, the logs say that Symfonium is trying to send an HTTP request to my HTTPS server. How do I enable HTTPS?

This appears to be a UX issue. I edited an old (HTTP) provider to add the new (HTTPS) URL, but this appears to be a hidden setting that I couldn’t change. Removing the old provider and adding a new, HTTPS one fixed it.

I recommend removing the host/port settings and adding a complete URL (together with protocol), so the hidden TLS setting can be changed.

I suppose the template you deleted had UX issues too :wink:

Anyway the save should not work if the host does not properly answer on http.

Logs would tell what happened to allow you to save.

It most likely did, yes. Even if it didn’t let me save, I don’t understand how I was supposed to recover from it. Say I add TLS to my server and want to change the entry in Symfonium, it appears that not only I cannot change it, but I will also not be given any indication that it can’t be changed.

What is the recommended way to change a server from HTTP to HTTPS, and how does a user discover this in the app? I didn’t see anything at all about that.

As said not only it should have failed but also tell you…

So provide logs reproducing ?