Subsonic API not working for Ampache

I use ampache which has a subsonic compatible api. Putting in my credentials doenst work and there are some errors in the logs:

debug.log (18.0 KB)

You enter the wrong url:

<title>404 Not Found</title>
<h1>Not Found</h1>
<p>The requested URL was not found on this server.</p>
<address>Apache/2.4.41 (Ubuntu) Server at Port 8081</address>

From a quick search you need to add /ampache at the end and need to check your rewrite rules. (Or your reverse proxy configuration if you have one in front).

Thanks for the quick reply. Tried adding /ampache to the end of my hostname and got basically the same errors. Not sure what rewrite rules to change but its worth mentioning that this server works fine with all other subsonic-api compatible apps that ive tried.
debug 4.log (33.6 KB)

Well I’ll need an access (even without account) to see why.

I suppose the server assume .view is required but it,'s not.

Sure, is there a way I can send you connection and account info?

Just click my name to send private message or from play store / the app the contact button for email.

Sent connection details in email. Thanks for your help!

@jbg Account seems invalid :frowning:

Fixed in next release! Thank you! Excellent support