Some Сyrillic fonts appear broken

Issue description:

some Cyrillic fonts appear broken. I tried to change the settings of displaying different fonts, but the effect is the same.


Upload description: I enclosed a screenshot and a music file

Additional information:

 Thank you and have a good day! :heart: 

Reproduction steps:

 Not provided 

Media provider:

Local device




Your file tags are corrupted Symfonium displays what the file contains.

MP3 tag:



Windows Media Player:

Not a single app can extract proper Cyrillic characters as they are not present in the file.

Yes it is an old file, but I can read it in Foobar2000 and AIMP player on mobile tel.

Mediaplayer Windows

Tested Foobar too

I have no idea what font or special thing make this works for you.

Have you tried in Symfonium the System default font?

Else you’ll need to figure out what font can display those and I can add it to Symfonium.

Ok, the last Hi-Fi Cast on mobile.
Thank you for your quick replay and efforts!

Ok so your files are not standard and encode the data in KOI8 that is not supported by tags in theory.

Seems some apps can use the system default text encoding to parse those, but Taglib does not support that so I can’t support that either.

There’s a few tools that could reencode the tags automatically to be proper UTF and then work.

1 Like