Some tracks don't play on Chromecast

I noticed that some tracks don’t play while Symfonium is casting on Chromecast. It stops playing and throws the “current renderer is offline” error, so the Chromecast device somehow doesn’t like the stream and disconnects.
What I tried:

  • tried different media servers (emby and navidrome), same error on the same tracks
  • play the same track casting from the official emby app: it plays fine
  • play the track locally, it plays fine
  • tried multiple chromecast devices, same error
  • it doesn’t happen with certain file types, the error occurs both with mp3 and FLAC files; tried checking the audio file but it doesn’t seem corrupted or with weird sample rates/bit depths (otherwise it wouldn’t play at all).

I know that Symfonium simply passes the stream but I’m intrigued by why the same tracks will play on the official emby or plex apps just fine. It happens quite frequently and if I cast a playlist the playback stops and never recovers. (69.8 KB)

There’s nothing in the logs that explains what happens.

2023-10-19 11:31:50.614 T:ChromecastRenderer
Playback started successfully (false)
2023-10-19 11:31:50.649 T:ChromecastSessionHandler
Cast state change to 2 (false) null
2023-10-19 11:31:50.650 T:ChromecastSessionHandler
onSessionEnded: 2055 null

The device accept the playback without error then disconnect the session by itself.

If it always happen with the same files I’ll need one to reproduce.
You can also download those files to your phone and try to cast from Symfonium.

In this logs this is navidrome so I can’t compare with Emby / Plex that might transcode.

Downloading the file does not change anything, it still errors out. I can provide a few files if necessary.
I switched to the emby media provider in symfonium and I still get the error with the same files. I did a quick shuffle through my library and noticed that all files that don’t play are FLAC, but they’re at 16/44 and other similar files play without any issues. I’ll keep an eye on which tracks error out and see if I can find any mp3s.
By the way, the same tracks play via upnp on the same device. Could this be a chromecast issue?

It is for sure a Chromecast error there’s no normal way to have the Chromecast close the session like that.

The question is what happens and if it can be detected / workarounded.

But yes files to test on my different Chromecast here would confirm.

How should I send the files to avoid any issues?

Upload somewhere and send a link by mail or chat here.

All those files works perfectly here, on Google Home and Google minis. From local device and Navidrome.

No idea what happen with your device :frowning:

That’s weird, I even tried from another phone and even manually transferring the files. Maybe it’s an older chromecast version…


Just bought a Google Chromecast with Google TV 4K yesterday and have exactly the same issue, some files are playing without issue and some others just make the cast session stopping…

It seams to be caused only on FLAC files like mentioned by @bogdansrb

I’m using an Emby Server ans casting directly from the Emby app same files works without any issue

Did you found any solution or workaround?

Open your own issue with logs and a file to reproduce.

I do have one of those device and previous file did work there.

If your Emby is accessible from Internet then an account on it with those files to reproduce exactly the same would be best.

Okay will do that, thanks for the quick reply

It seems that something is broken in the newer versions of the chromecast. I reverted back to an older version and the issue is gone.

1 Like

Hmm interesting, and how Can you downgrade a Google Chromecast can’t find any way to do it?

Thanks in advance

I have a Mi Box S device and it appears in the app list, meaning I can uninstall updates.