Random not working ? (smart playlist)

Issue description:

I have a smart playlist. When I want to play it in random mode, it’s playling as is, not randomly

Logs

Please add more details about what you do …

In the logs you seem to start the playlist once in random mode then 3 times in normal mode. Each time you start a playback it cancel what’s it’s currently doing so the last one wins and it plays in normal mode.

I’m actually just clicking once on “Random”

Let’s try again:

Please add more details about what you do…

Playlist definition where do you start it and how, make a video? (There’s nowhere the word random in the app)

Logs does not match your description.

The smart playlist was already created. I just open it and press “Random”, or “Aléatoire” in french, I don’t know how it has been translated.
Here’s another log and exactly what I’ve done once the debug mode has been activated:

  1. Go back to settings (from Advanced)
  2. Go back to main screen
  3. Press the shortcut to go to my library
  4. Press Playlist
  5. Press my playlist (“Unplayed tracks”)
  6. Press “Aléatoire”
  7. Open the list playing to check if it’s random: It’s not
  8. Back, back, settings, advanced, disable debug mode


Ok, when seeing my screnshots, I get it: it’s “kind of” random, but it’s not randomized by tracks:
It seems to randomize songs within an album, but albums are still played in the same order as they’re listed in the playlist (in my case, by added date).

So, for instance for my playlist, let’s say I have 4 albums, A, B, C, D, in this exact order.
Random mode seems to play the albums in order, but to randomize tracks within the albums.

Ok so yes it’s random but your first order of date added is applied and seems your songs have exact same one leading to this…

Will see if I can manage that differently.