Plex music takes a really long time to start playing

Issue description:

Hi - when I am starting playback of music that hasn’t been previously cached on Symfonium - it takes a really long (15 seconds or so) time to start playback.

I was ready to blame my plex server (and usually I cache/download anyway) - but I don’t get the same behaviour through the Plex native app - this starts within a second.

I have just shared my debug logs via the app under the name ‘kevinblake’.

Is there something I’m doing wrong, or a setting I should change to speed this up?

Thank you!


Upload description: kevinblake

Additional information:

 Not provided 

Reproduction steps:

 Not provided 

Media provider:




128Mb of playback cache is not a lot, but your Plex is insanely slow in those logs.

40 seconds for ffprobe, and an insane time to load the first 256K of the media.

Check Plex logs, you maybe have some limits set up like number of simultaneous connection or other that makes everything slow like that.

You can try to disable playback cache to avoid multiple load at the same time to test too.

Thanks @Tolriq - I appreciate the fast reply (as always). So you think it is the Plex server end, from what you can see? It does run on a ShieldTV device, so maybe it just isn’t up to the job - I just wasn’t sure as the native android plex app is still super fast.

I do notice a couple of errors in the Plex server logs that occur when playing from Symfonium, but don’t appear to be there from the Plex native app

Unable to find client profile for device; platform=, platformVersion=, device=, model=
ClientProfileExtra: music transcode target already exists for streaming http

But I don’t expect you to debug my Plex setup. It might just be that I need to move the Plex server to a more powerful device! :slight_smile:

So slow is not the device the shield should be enough as there’s no transcoding.

Can be the router or proxy.

Try to add the plex server without but just locally with the lan ip by skipping the first part.

Thanks - using the local IP doesn’t appear to make a difference.

However, interestingly… Those errors mentioned above go away when I change PlaybackSettings/*Maximum bitrate values to something below the source file. And then, for example, a 320kpbs mp3, with max bitrate 192kbps starts to play very fast.

If I choose another file that’s already encoded at @ 192kbps (and so obviously doesn’t require the plex transcoder) - and it’s a slow start again.

Makes no sense, no idea what the server does when no transcoding. The app request the raw file.

Maybe some settings on the server that still tries to transcode and fails.