Playlist over upnp ignored, first song repeats

Issue description:

When streaming a playlist to a UPnP speaker, the first song of the playlist continually repeats. I do not have repeat selected but it won’t get past the first song.


Upload description: lightsout

Additional information:

I was using the app all day yesterday in my car with Bluetooth and I did not see this issue.

Reproduction steps:

When playing files over UPnP The app plays the same song over and over instead of playing through the playlist that has been selected.

Media provider:





I tried to add a new issue and it brought me back to an old issue I had posted so I edited it. Hopefully this will be seen invisible. I have uploaded the logs through the app with my username.

I just uploaded a new log titled “lightsout2”.

I disabled UPnP, connected to the speaker over Bluetooth and the playlist began to play as expected, songs started to advance in order.

The logs does not show everything including the start of the media so it’s hard to tell.

But have you tried to reboot that device, it’s possible it have an internal state to repeat that is not reseted as not supported by UPnP.

I’ll try that and report back.

I did the reboot, went straight to the app, turned on debug, connected to UPnP speaker, went to an artist and selected play on one of their albums.

Upon playing the first song I scrolled to the end leaving a few seconds. Failed to skip to the next song but repeated.

Sent new log “lightsout3”

Try to disable Gapless support on the renderer settings in the cast bottomsheet.

Still doing it. Tried playing from local and going back to UPnP. Same thing.

Provide new logs without Gapless, be sure to strop casting then select the device again just in case.

Done and sent “lightsout4”

Well the device seems completely broken.

It restart the media on it’s own and never says that it’s stopped so that Symfonium can play the next song.

Never seen that and repeat mode is not part of UPnP specs.

Can you triple check that on the Heos app there’s not a repeat mode toggled or a repeat mode in a physical remote?

That’s really strange. Thanks for looking into it. I have 4 HEOS devices, two speakers and two avr’s. All different models. I’ll try them and see if one or all does it. I looked in the app for a bit for a repeat setting being on but didn’t see it. But need to look further. I’ll report my findings.

Oddly my wife was complaining about the same thing a few weeks ago just using the native emby app. That is was playing the same song over and over. I don’t think she was using upnp, probably airplay.

Shoot man don’t kill me for wasting your time. Tested on another 2 HEOS devices and they worked great. Power cycled the speaker and it’s working normal.

I was focused on the app/phone didn’t think about the speaker itself. Thanks for the help as always.