Playlist Not Correctly Importing From Plex Linux Server

Issue description:

In the process of migrating between Plex servers. Moving from Windows to Linux. On Plex, my playlists are correct on both servers, with the number of tracks, and the track itself has correct metadata.

When using the playlist import feature, the playlist imports, but the tracks are scrambled. It includes tracks that aren’t even in any playlist, and the number of tracks is wrong. This isn’t the case when importing from my Windows Plex server. Both servers are on the latest version.

Repeating the process yields the same results with the exact same tracks in the playlist. Same with using the different import modes.

Two log files are attached, one for importing the Instrumental (read-only) playlist from the Windows Plex server, and the other from Linux.


debug-windows.log (250.4 KB)
debug-linux.log (119.5 KB)

How are you doing your migration?

Your linux server returns the same media IDs for the playlist content but those IDs does not match the data that they returns as their library.

I should of added that the “linux” Plex server is technically a QNAP NAS. Plex can be installed through their app center.

Also, I used soundiiz to import my playlists by downloading a csv of the playlist from the Windows server, and using soundiiz to import. I’ve used it in the past with no issues. I created a normal playlist with 5 tracks and still got the same issue (with the same incorrect five tracks), so I don’t think the playlist import is the issue.

I guess the next step is for me to create a normal linux Plex Server and see if it imports correctly. I would guess a few users are here would use Plex Linux and haven’t run into the issue so it may be the NAS app.

Your issue is about the Plex IDs returned.

I don’t know how you creates the new database and everything but on Plex your IDs are different.
But the playlist returns the same IDs so Symfonium matches what it can with those IDs (so different or missing songs)

A fresh Plex with fresh playlists will work. The issue really is about the data being wrong. Or you did something special on Symfonium side by trying to edit an provider to switch to the other and did not force a sync.

I can’t guess but you need to ensure coherence on all parts.

I tried syncing with the provider after the playlist import but everything stayed the same, I also tried a Media Provider Sync. I could also try a reinstall of Symfonium, but it sounds like Symfonium is being given the incorrect ID’s by Plex, so it’s a Plex issue?

Ah, good news, sort of. I created a new playlist on plex, but added 5 songs that weren’t on any of my other playlists and they imported fine.

Yep, you’re right, something weird is going on, maybe it was the Soundiiz import. The playlists are almost like symbolic links, rather than standalone playlists. I deleted Instrumental from the Windows server, and now it won’t show up on the Linux one, even though I didn’t touch it. Going to try the import again, maybe with a different file type.

I imported a playlist that contained a couple songs that were on Instrumental and it now works, because Instrumental is deleted on the Windows one.

Worst case I delete the playlists on the Windows one and recreate them from scratch.

Either way, this doesn’t seem to be a Symfonium issue. Thank you for your help, keep up the great work!

Well this is half Symfonium issue in the sense that it only support Playlist that points to actual content of the server and what you did is something else.

In all cases that would have broke when you shutdown the windows server.

And there’s no plans to support that kind of playlist as it’s not compatible with the offline first internals.

Yeah, I think the playlist is being imported using the Windows server media library. If you try to import while the Windows server is down the playlist is blank. I’m not sure how I got it to work previously. I would think the media libraries would be the same, as the path is the same. Maybe I have to name them the same? I could try that.

I manually recreated the Instrumental playlist making sure to select from the Linux server’s library and everything imported fine on Symfonium.

Oh yeah, I was wrong. The reason why it’s on the NAS, is so it has local access to the media, so technically the path isn’t the same.

Probably why plex is showing it as two media libraries and is messing everything up. The path to the files are different? Though I would think it could just query the database, so the location of the media library wouldn’t matter. I’m not familiar enough with Plex.