Playback resetting whenever network origin or strength changes?

Issue description:

Ever since I got my brand new Google Pixel 8 Pro, I’ve been experiencing this weird issue with my playback. Whenever I switch network strengths (i.e. Internet to 5G, 5G to LTE, etc…) my playback from my Plex server seems to restart from the beginning. I have the offline rolling cache enabled, with up to 9 songs on cellular and 4Gb. I have some logs from the day, most recently occuring on the song “Instruction” by Jax Jones.


Upload description: Moonstar

Additional information:

With my new phone, I did switch over to a new carrier. I cannot get this to reproduce on my old Samsung S20FE also, which is interesting.

Reproduction steps:

Begin playback of Plex Server, using home external IP address instead of server domain. Then, began taking a walk around my home town in order to get the cellular to constantly fluxuate.

Media provider:




There’s a few different strange things.

Depending on how you are connected your phone switch to a state where it returns error 404 for the requests to the server so something intercept the calls.
Maybe you have auto connect to some wifi in the area that needs manual authentification ?

And Plex wants to transcode the file in other cases and it failed. Can you provide that exact file? and tell me when it’s done?

I have uploaded a zip file containing a few of the songs that I have seen this issue occur with. Since my phone is brand new, the only Wi-Fi network it has in my home town is my house, and this issue occurs everywhere I go, no matter how far.
What is weird is that fact that these songs are in my offline cache. Shouldn’t it just default to using that instead of the Plex connection?

Your songs are not in the offline cache, they are maybe in the playback cache but in that case it still requires a server connection to decide the file format.

And your files are webm/opus with .m4a extension reason why it tries to transcode. I’ll update the profile I sent to ensure there’s no transcoding.

1 Like

I see, my bad on that distinction. Thank you for the help on this. Symfonium is probably the best music app I have ever experimented with for my use cases, so I am glad that it sounds like I will still get to use it with the new phone.

Well on my side I can only fix the request for transcoding you still need to find why your phone returns 404, or actually use the rolling cache by enabling the option to copy from playback cache to offline cache.

That option is, and always was, enabled (hence my confusion on why it wasn’t using the offline cached version). I can see the songs in the offline cache, but it still restarts playback. As for the 404, I wouldn’t even know where to start with that.

What options have you enabled? In the last logs the files are definitively not in the offline cache and the option to copy to rollingcache is not enabled.

I’ve attached some screenshots to show you, but I’ve set my rolling cash to 4 GB and I’ve set my playback to automatically save songs to the rolling cache. On mobile, it’s set to nine songs, while on Wi-Fi. It does nothing since I won’t need the cash due to a stable connection.

Well in the last logs your phone says you are connected to wifi most of the time, so maybe that’s how your provider expose stuff to Android ?

And so you still should enable it for wifi.
Still strange that the current song is not cached after.

1 Like

I’ll turn on Wi-Fi song caching, since the Pixel 8 Pro just has a “network” tab that shows both internet and data in it, so there may be a weird distinction there. I’ll report back tomorrow to let you know if it worked, since I won’t be able to do a walk for another 6+ hours or so.

It seems that enabling the cache while on Wi-Fi has rectified the issue. Now I can go back to using my favourite music app.