Playback of flac files over UPnP does not work

Issue description:

As the title states, I cant play flac files over UPnP at all. It simply stays paused at 00:00. Using navidrome server.

Logs: (2.8 MB)


Additional information:

Besides not being able to play flac files over UPnP, flac files have been bugging me for a long time. Local playback of them doesn’t work very well either. I can’t seem to seek to specific times, as it jumps back to the beginning of the song. (maybe i should open a seperate issue for this?) Also, (flac) songs often randomly restarts for no apparent reason.

There’s many different things here.

  1. If you force transcode on the server side Symfonium can’t properly detect that and seeking can / will be broken. (This can also cause issue to UPnP as the format won’t match). If it auto restart when playback it means network too slow and the client tried to seek to recover. Enable playback cache in the settings to prevent such kind of network issues.

In this log the device accept the play command then fails later, could be a bug in their gapless support so uncheck the option in the setting (then stop cast then select the renderer again).
And be sure to not transcode on server side.

Else you need to check Navidrome logs if there’s errors when that device tries to reach the file.

Okay, thanks for your response. I have tried playing around with the settings a bit and I can say that gapless playback is not the problem. In fact, most flac files play fine now. (Im not sure this was the case before as well, or if I changed some setting) But the problem remains for certain flac files. Upon closer inspection, it seems that 24bit flac files are the problem, as 16bit plays fine. I don’t have many of them, but it would be nice to get them to work as some of my all time favorite songs are 24bit flac. Any idea what the problem could be?

Nevermind, the problem is not specifically 24bit flac files, but 24bit flac files with a sample rate of 96kHz…

Well you device probably just do not support those.

Right. Besides UPnP, I can’t seem to control the volume of said flac files (24bit 96kHz) on my local device. I have no problem playing them otherwise.

There’s no media volume control, only your phone device volume, it’s not possible that volume control does not work for some media.

Well, its definitely possible in some way as I have the problem. Instead of playing at the specified system volume it plays at either max volume or the specified volume when the song was started, after which it is no longer possible to change volume. I can shut the volume off completely and it will remain at whatever volume. Works fine in other subsonic clients on my phone.

Only possible way would be that you have enabled offload mode and your device have a bug.

Open new issue with logs details and video.