Playback does not make it to the full playlist

Issue description:

Here is the problem.

I would like to play my music from my NAS to my All-in-one MusicStreamer.
The files are stored on a QNap NAS.
The music server is powered by Emby. But the problem is the same with Plex.

The All-in-One Music Streamer is a device from a brand called Shanling.
The model is an EA5 that includes everythig : streamer, DAC, heaphone amp and power amp.

If I launch Symfonium I can find the Emby Library on my netwrok without any problem.
I can also see the Shanling EA5 as a renderer. No problem here.
I can launch the player and stream files from the NAS to the Shanling without any problem.

So ? Where is the problem.
The problem is here.
I want to listen to a full album. So I start the playing of that album.
And there… the playback randomly stops. It can be after the first track ; it can be after playing 2/3/4/… tracks.
If I am lucky, I can play the whole album… but that rarely happens.

I have included a log file that should show following on the playback of a 4 tracks album :

  • After first track, I had to go to track 2 manually ;
  • Track 2, 3 and 4 started automatically one after each other…

I then tried an album with much more short tracks (2/3 minutes tracks) :

  • First track plays OK but have to manually go to second track ;
  • I had to manually go to track 3 after track 2 was done ;
  • Track 4 played automatically after track 3…
  • I had to manually go to track 5 and then to track 6… That’s is where I gave up.

Additional information:

  • 1°) that problem did not occur when I played files over NAS to the RaspBerry Pi4 Streamer.
  • 2°) if I try to play the same files to the same streamer with other software (i.e. : Buble UPNP or Emby for Android) they do not go to next track AT ALL (so Symfonium, besides being the best, is also the one that works best… mConnect manages to get same resut as Sympfonium, but is REALLY less convenient than Symfonium…)
  • 3°) before posting this, I have installed latest Firmware on the Shanling player and reset it to factory default (it is powered by Android custom version) and made sure I am running Smfonium on a not too heavily modified Android version (it’s running on a Motorola phone that has been reset to factory defaut before I used it)


  • Join files do not paste the content of the files here !

Here’s the link to the log on Google Drive :

I think I also joined the .zip file of that log… But not sure. (797,4 Ko)

{CurrentTransportState=PAUSED_PLAYBACK, CurrentTransportStatus=OK, CurrentSpeed=1}

Your device says that the playback is paused and not stopped, so it’s normal that playback does not continue.

If that device support gapless try to enable upnp gapless in the settings. But since it’s off you probably have disabled it because it’s worse :slight_smile:

In all case this is a device bug that can’t easily be workarounded.

Hi Tolriq,

Thanks a lot for the answer.

Yes, I deactivated the gapless support but will re-enable it.

I suspected that this was device related… but was wondering if maybe there was a way to “force” the playlist to continue to be read.

I’ll report to the manufacturer but I have little hope he’ll do anything about it…
But I’ll apprecite if he would as that would allow to continue to use Symfonium instead of the “not so evolved” software that drives the device :slight_smile:



The problem is that without owning the devices building workaround is really hard, as I must ensure that it does not break normal working devices.
Being paused is a normal wanted status, so it would require to properly identify that this is this broken device and find a way to detect that the song has played till the end and it’s not a wanted pause.

Many ways to get this wrong.


Thanks a lot for the info.

I’ll report this to manufacturer. That it seems it’s device sends a “Pause” command that should not be sent. By any chance, can this be a hardware problem ? As it happens only randmonly (sometimes tracks are played through the whole album, sometimes they don’t), I suspect it might be… then again, it would also do it randomly with other software… which PAUSES after first track every time.

If you want me to try out some “unreleased beta” software (like an .apk), I can of course do that :slight_smile:
And would be more than happyt to do so :stuck_out_tongue: because the device is really nice (superb sound and really practiacal compact size). But of course, taht would be a LOT OF TIME for only one user (or a small amount of users) and I’ll understand if you can’t do that !

Regards from France.


It does not send a pause command.

It says that it’s in a paused state.

I returns:

<?xml version="1.0"?>
<s:Envelope xmlns:s="" s:encodingStyle="">
<u:GetTransportInfoResponse xmlns:u="urn:schemas-upnp-org:service:AVTransport:1">

instead of

<?xml version="1.0"?>
<s:Envelope xmlns:s="" s:encodingStyle="">
<u:GetTransportInfoResponse xmlns:u="urn:schemas-upnp-org:service:AVTransport:1">



So if I get it right, the player says it is into Pause and as such Symfonium does not send the next track is taht correct ?

That explains why if I delete the current playlist from the device, playback starts again from within Symfonium.

I will ask a stupid question (as I am no developer) but is is possible to add a command like “If player is in pause send play command” or something like that ?



As I just explained, yes it’s possible but you do realize the side effect that you would not be able to pause the playback anymore :slight_smile:

Being paused is a normal and often wanted state, I can’t just ignore it.

Hi Tolriq,

See… I am no dev.

Did not thought about that :frowning:

I see where the problem is and that the only reasonable way to fix it is to hope for a new firmware from manufacturer.

Fingers crossed :slight_smile:

So one LAST question : as I understand it, the files are sent one after the other to the device. Is that correct ? If so, would there be a way to send the whole “set” of files instead of sending just one after the other ? That would possibly solve the problem, but as I have NO IDEA how DLNA and UPNP really work, this is possibly not possible with those protocols…

Thanks again for your software an dtime to reply to messages.



Do not edit for question as there’s no mail sent.

And again as explained this is what Gapless mode do (But only more song) and most device do not or badly implement it.