pCloud playlist import doesn't find any media

Issue description:


I recently saved all of my music files in a folder in pCloud, and I can play them just fine. However, I wanted to import my .m3u playlists but no media is found, so the playlist import fails.

I placed my .m3u are placed in the same folder as my other music files, and that their directories in the .m3u are listed correctly.


Upload description: Logs for pCloud playlist import issue

Additional information:

I also posted contents of one .m3u playlist file to show that the directories are indeed correctly listed.

Reproduction steps:

Steps to get the issue:
Files > pCloud > Music folder > playlist file - click the 3-dots > Import
No matter if Read-only is activated or not, no media will be found in the playlist import and it will not work.

Media provider:

Any provider




Starting with / means that it’s absolute path, not relative to the playlist.

So since the media are now in a subfolder they can’t be found.

You can use ./ to say it’s relative to the playlist or the actual full path that you can see by pressing 3 dots on a song then details.

Yeah, you’re right, I dunno why I didn’t try this actually.

I tried with ./ and with absolute path too, but it still doesn’t work. For instance, here’s the path of one music file, and the .m3u playlist with absolute paths for each file.

Can you try without the / at start then to see?

And provide logs for absolute with / and without ?

Hell yeah, it worked without the /, just like this.

Thanks a lot!!

This is still strange will try to repro.

Next release will have more logs so I may ask you to provide more logs with it if I can’t repro.

Ok so did repro a small issue specific to pCloud.

Most cases should be fixed in next release.

1 Like