Orphan media sessions on Android 11

Issue description:

Hi, after a few days of usage, I noticed that the number of active media sessions was too high and almost all of them are from Symfonium. I’m not sure how to capture logs for this one as I wasn’t able to reproduce it immediately, but the screenshots should show you the issue at least.


Upload description: prone-to-drift media-sessions-1

Additional information:

 I don’t have any, sorry, but I’m open to suggestions to gather more. 

Reproduction steps:

 I don’t know what exact steps are, but normal usage? Actions that I’ve taken so far:

Use the app, forget, come back after a few hours, use it more.

Go offline, go online and sync.

Use different queues.

Change the phone language as well. (The media session still shows the media output device in the language at the time as you can see in my screenshots. 

Media provider:





In the log file “prone-to-drift media-sessions-2”, I clicked on one of the play buttons on those leftover sessions and it continued the playback from the latest and properly displayed notification. The button didn’t update. Pressing the play hutton again had no impact when the audio was playing.

Finally, I paused using the latest notification and uploaded the log.

This is a bug on your OS. It is impossible for an application to have multiple media sessions, so even if everything was bugged in Symfonium there could not be multiple visible sessions.

Check the battery settings for Symfonium the OS probably kills the app the hard way and prevent proper release of the session, but even then on restart the session should replaced by the new one.

From what I can see Google fixed that in some patch so maybe you missed some updates?

I think you can workaround by swiping the session then change some settings there.

1 Like

I figured this one out. Some Android 11 bug for sure, but it’s triggered by altering the settings of the notification/media session in Symfonium. Each time you change something, a new media session is shown without removing the previous one and swiping doesn’t close it either.

Reboot is the fix. Simply reboot after you’ve configured Symfonium how you want.

1 Like

Thank you for following up, I was about to open a support issue for this exact thing.

1 Like