Not showing music files from Navidrome server

Issue description:

  • Add as much details as possible, including reproduction steps.
    First of all, thanks for developing this app, it’s the best app I’ve found for Subsonic music servers.
    I had my navidrome server running and have now migrated to another server. After I had set up everything on the new computer, I connected to it with Symfonium, but it does not show the music files at all anymore. I’ve tried to connect with and without https and also by using the ip address of the server and using compatability mode (not included in logfile but I could send them if they’re helpful), but i couldn’t get it to work.


  • Join files do not paste the content of the files here !
    Symfoniumlog.txt (264.5 KB)
    (this is the debug.log filef from Symfonium, I renamed it)


Additional information:

---- Technical details, do not remove ----
Symfonium: 2.1.0-816 [true/0/138/84]
Android: 11 - 30 [arm64-v8a,armeabi-v7a,armeabi]
Device: DOOGEE - S97Pro [S97Pro_EEA - S97Pro]

Your server does not return any genres and it seems that it triggers a strange path inside Symfonium.

Is your server accessible remotely and can I have a test account to the same library to reproduce and fix?

I just have it running locally on my lan, but I could try adding genres and everything to the music files if that might fix the problem. I thought that wouldn’t be a problem since it worked before. I could send some zipped folders with music files if that would help. Also thanks for replying that fast

Adding genres will fix, I’ll workaround the strange result returned by your server.

Ok thank you I’ll try that :+1:

edit: It works now, thanks for the support

I have the same issue, but my server does show genres.