MP4/EAC3 (Atmos) Playback

Issue description:

My songs with Atmos doesn’t work. Playback timer goes up, but there’s no sound.
I mainly use Subsonic (Navidrome), but also tried with Jellyfin as provider and local file playback. (Behaviour is a little different but still no sound.)
Changing transcoding settings in app doesn’t help in any way.


Upload description: logs when playing with subsonic

Additional information:


  1. Playback with subsonic
  2. Playback with local file

Reproduction steps:



Media provider:

Any provider




The logs does not contains the start of the media so I do not see what codec ExoPlayer see and how your device react at start.

Please upload logs starting before starting the media.

Hope, now I got them right.

Yes better.

Unrelated but you enabled the Virtualizer but your device does not support it

2024-03-06 18:28:41.409 Error/MusicPlayer: Error creating virtualizer
java.lang.RuntimeException: Cannot initialize effect engine for type: 37cc2c00-dddd-11db-8577-0002a5d5c51b Error: -3

So yes a check think that ffmpeg can handle it but it’s not compiled with eac3 so fail after. Will add support for that in ffmpeg.

You can try to uncheck the option prefer internal decoder in case your phone have the proper codec but I do not think most device have them.

Thanks for info.
I should just wait for future update, right?

If you can check without the option to see if that work it’s still useful information, but yes I’ll add support for eac3 in next release no reason it does not work.

Disabling prefer internal decoder doesn’t change anything (no matter the provider). I suspect that it is included in logs, but phone model is Nothing Phone 2.

Ok so EAC3 is still protected by patents and I’m not allowed to fully support that without paying like 8$ per user + use their things that are not compatible.

So while EAC3 with AC3 fallback stream will work, I cannot officially support EAC3 and Atmos.

That sucks, but is completely understandable. Thanks for quick help.