Lyrics (with .m4a-files) seemed not work with Navidrome V. 0.49.3 in Symfonium

Issue description:

Hi there and thanks for the great app symfonium.
I’m using symfonium V 6.0.0 (1148) in addition with navidrome music server (V. 0.49.3) to play mostly my music in *.m4a format at my android smartphone (Android 13, Kernel 5.4.210). Playing music works fine. But it seems to be impossible to play lyrics on *.m4a-files. When playing my music with the embedded “LYRICS” tag (synced lyrics) in the navidrome web UI, then all plays fine. When playing the same files at symfonium than the lyrics works only with *.mp3-files. The lyric button doesn’t show up while playing *.m4a-files.

Again: at navidrome web UI it works with both (*.mp3 and *.m4a) and it seems to be supported to use embedded lyrics with navidromes api. So i was aking if i can configure anything for work with symfonium.

For the attached logs, I’ve disabled local cache und cleared the same. Then I synchronised navidrome in symfonium and search for the test title “Megaherz - Falsche Götter”. The first file is the version in *.m4a (with embedded synchronised lyrics). The music played fine but without lyrics. After that I played the same version as *.mp3 (again with embedded synchronised lyrics) and the lyric-button appeared instantly and works fine.

Unfortunately 80% of my music is coded in *.m4a and i don’t want to recode them. So maybe there is anything else i could do?

Thanks for checking.

Logs: (4,1 MB)


Unfortunatelyi can only add one attachment (as new user) so the post was refused with additional screenshots.

Additional information:

Navidrome is installed containerized (in version 0.49.3) at an mini linux home server running at debian 6.1 and docker-compose.

I will need one of those files to repro.

But can you show me the exact error when you add more than 1 images? The limit in settings is 5.

hello tollriq,

when adding more than one attachment i’ll get the message: “Ein Fehler ist aufgetreten: Entschuldige, neue Benutzer können leider nur ein eingebettetes Medienelement in einen Beitrag einfügen.”.

Hum so specific to multimedia :frowning: Will see if I can find a setting for that.

But I’ll still need the file to repro, ExoPlayer does not see the lyrics in your files.

edit: Ok found, it’s “newuser max embedded media” and not the max attachement that is applied here.

This file works without any issue.

Since you are using playback cache all I can suppose is that you added the lyrics after the file being cached and need to clear the playback cache (In advanced settings).

Oh. Yes, you’re absolute right. After deleting cache in advanced options it works well. I deleted the cache at “Manage Offline files” before. But this seemed to be the wrong way.

I was wondering why “details” showed “Cache: no” as i tested it.

But now it works fine. Thank you for support. I appriciated it.

There’s offline cache that ensure that media are present and there’s playback cache for network issues but without any insurance files are complete or present.

That value is the offline cache status, the playback cache status can’t really be checked.