Intermittent Progress Indicator in Emby even with Latest Beta (9.0 B2)

Issue description:

Testing the new beta V9.0 B2 to see if issues with the new Emby 4.8.1 API have been resolved. I do see the “user has authenticated on server” messages again, however the playback progress still doesn’t appear like it used to with Emby 4.7.


Upload description: mattl1979

Additional information:



Reproduction steps:

Connect to an Emby 4.8.1 administrative dashboard. Play a song within Symfonium. Notice the progress sometimes works, sometimes shows up for a second, or doesn’t show at all. Activity log will usually show started playing and stopped playing at the same time. Still some API call issues unfortunately.

Media provider:




I send what he told me to send and it returns OK.

This works here, so this is more something again for Emby to explain what changed.

Understood. Hopefully the Emby dev team will provide more details into their API changes. Obviously something is still off for their new version, unfortunately. Definitely getting somewhere though as before beta 2, nothing at all would show. It’s at least showing authentications now + intermittent progress.

You’ll probably need to post again in your issue there with new Emby logs so they can tell. Here on 4.8.1 the dashboard properly shows everything when I added the sessionId. And in your logs the sessionId is properly sent.

I’m not expert in Emby logs to understand why it would not work if the API answer OK.

1 Like

I did repost there, but it doesn’t appear Luke has seen it or replied to it. In the interim, have you done any additional testing? I’m happy to test something for you if you’d like.

Edit: I also tried using B2 with Jellyfin. Interesting behavior that may help you. I do see the time indicator, similar to how I did with Emby v4.7, however the indicator kicks on, goes away about 1-2 seconds later, at which point the activity log says “stopped playing”, but the song continues and the time indicator re-appears. When I actually stop the song, the activity log says “stopped playing” again.

Provide new logs from beta 2 with matching Emby logs.

Same for Jellyfin.

How do I attach the Emby and Jellyfin .TXT logs here?

Great, perfect. You should have 2 logs from Symfonium, an Emby log, and a Jellyfin log.

Can’t reproduce anything with Jellyfin 10.9.

For Emby seems there’s some bugs on their side too :frowning: You are using playback cache, and it seems the new system does not support multiple sessions at the same time from same device, so when Symfonium pre load the next media the current one is hidden …

And when media are fully cached in playback cache for the moment I can’t start a session to get the new needed id since the media are not played from Emby.

Will see how it goes but this won’t be workarounded for 9.0

For testing, I turned off the playback cache (which I would normally not do since cell service generally sucks around here, LOL). Anyways, here’s what changed:

  • Emby: Time progress shows 100% of the time, however the activity log never shows the start entry (user is playing), but only that I stopped playing (user has finished playing).
  • Jellyfin: Sporadic but much better. I think it’s a bug in JF more than anything. The time progress shows up 98% of the time. Sometimes I need to hit pause then play to get it show. Activity log shows both events, playing and stopping.

All in all, I am thinking of going back a previous version of Emby. It just … works! That said, I hope you can work out the kinks in the new API as definitely something is awry. Your explanation makes perfect sense though!

Edit: Oh, if it matters, my Jellyfin instance is in Docker and v10.8.13.

What’s the latest on this? With Symfonium 10 + Emby v4.8.3, I do get a proper and consistent user started/stopped playing media log entry, but the “Now Playing” status still doesn’t work. It seems like it tries to show up for ~0.5s, but then nothing. Are we still waiting on changes from Emby devs?

The fix is on their side for that part, everything was changed to their new way. Nothing more I can do on my side.

1 Like

Thought as such. Appreciate the update!