Initial sync of Navidrome never finishes and crashes app

Issue description:

Add my Navidrome server using “Subsonic” media provider. This was working previously, but recently the sync is never able to complete and after a minute or two the app will crash and send me back to Android home screen. If I re-open the app, the sync has restarted.

At this point, I cannot change or remove the Subsonic media provider from the settings either, and have no choice but to uninstall Symphonic to prevent constant battery drain due to constant sync. Have re-installed and tried from fresh a few times, same result.

I’ve used this app and media provider for a while, is a new issue.

Navidrom version = 0.51.1


Upload description: tmowbray

Additional information:



Reproduction steps:

Install Symphonic, add “Subsonic” media provider for my Navidrome instance.
Initial sync starts…seems to get to the end (number of artists, albums, songs appears to be correct)
App crashes after a few minutes, music library never populated

Media provider:





Your device kills the app because the phone runs out of memory, but it’s not Symfonium else it would actually crash via OOM, specially with the app in foreground.

Have you tried to reboot your phone?

Else I’ll need a full bug report Capture and read bug reports  |  Android Studio  |  Android Developers

Be sure to upload it to .

I just did a phone reboot and tried to re-install app and try again, still same behavior. I’ve uploaded a new debug logs from the app labeled with my forum username as before, and also submitted an Android bug report as instructed.

This is a Pixel 8 with latest Android software update.

EDIT: Also, I don’t see any errors in the Navidrome logs, other than a “test” user hitting the API when I first setup the Subsonic media provider, which I assume is just to test connectivity and expected.

In those logs I do not see the app killed at all? Just a block at the end.

Can you eventually provide me with a access to the server so I can try to reproduce in case there’s something special in your data ?

The problem may be that the logs seem to reset after the app crashes, so it’s not capturing that, or am I trying to capture it at the wrong time?

I’m not sure I’m comfortable providing access to my private server… will probably just uninstall app and look for another solution.

The logs don’t reset after crash and contains the reasons when it’s restarted, in your last logs there’s not restart.

From where the logs stop and the out of memory outside of the app, it looks like the artist genre creation query breaks your OS sqlite.

Since it only seems to happens to you, without a way to reproduce it’s impossible to workaround.

For the record numerous people already gave me temporary access to their server. You create an account I repro, fix and you delete the account.

Is there a way to send you a private message with that info?

Click on the image near my name then chat or message.

Okay, I guess my account is too new and it won’t allow me anyway