Improve handling of Plex relay servers

Issue description:

I use Plex to host my music, but when trying to play some songs from that server it gives me this “Error playing media, ensure that your player supports it.” message


debug.log (150.1 KB)


Additional information:

Your server returns error 400.

Can you check Plex logs for the details?

Would you like me to attach those logs too?

Plex Media Server (5.0 MB)

[Req#e697] Streaming Resource: Cannot make a decision because either the file is unplayable or the client provided bad data

Yes that kinda match the strange data returned by Plex

{"MediaContainer":{"size":0,"allowSync":"1","directPlayDecisionCode":1000,"directPlayDecisionText":"Direct play OK.","generalDecisionCode":2000,"generalDecisionText":"Neither direct play nor conversion is available.","identifier":"com.plexapp.plugins.library","librarySectionID":"9","librarySectionTitle":"Lidarr","librarySectionUUID":"adc9cfd1-bf9f-4081-9a4f-da76ca73d4cd","mediaTagPrefix":"/system/bundle/media/flags/","mediaTagVersion":"1667288622","transcodeDecisionCode":4005,"transcodeDecisionText":"Cannot convert this item. No conversion audio and video encoders could be found in app profile."}}

It says: Direct play OK.
But at the same time says: Neither direct play nor conversion is available.
and size: 0

Does those songs work on the normal plex app? Maybe you moved some data and Symfonium did not detect the change and might require a force sync

I tried the songs in Plexamp and they work.

Tried this. Alas, no avail

First time I see this kind of answers :frowning:

Are you able to give me a temporary access to the server to try to reproduce ? (You can invite support at

Yep, just sent you access

Ok got it, still not had my morning coffee but will look into that in the coming hours.

1 Like

Well so I can’t reproduce at all.

Exact same query but different result

"size": 1,
"directPlayDecisionText": "Direct play OK.",
"generalDecisionText": "Direct play OK.",

And everything works fine.

The only difference is that in your logs you are connected via the Plex relays and not directly. They maybe prevent playing the media in that case if the bitrate is too high. Unfortunately since the relay will nearly always answer there’s little chance Symfonium return to direct IP automatically :frowning: Would be nice to had logs of why Symfonium switched to that one to I can better handle a try to return to better connections.

Anyway removing the host and adding it again will almost certainly fix the issue, I’ll need to figure out the relay thing :frowning:

Hmmm, I see. But yes removing and re-adding the server as a media provider did work! I wish you luck on figuring out the relay thing

If this happen again to you, then you maybe will have a way to repro that and would love if you opened a new issue to help :slight_smile: