Imported playlists into Jellyfin can't be read

.m3u* playlists scanned into to Jellyfin are not loadable by Symfonik.
Playlists created using the Jellyfin UX are both visible and completely functional in Symfonik 0.9.5 but playlists created on import of.m3u(8) files appear empty.

The logs don’t provide any insight here but to recreate, import (don’t create) a playlist into Jellyfin and try to read it on Sympfonik.

Logs are always mandatory … You already have them it’s 2 seconds to send

Tring to reproduce will take a lot lot more time and may even fails if not same version, same configuration or a million other reasons. Multiply that that by the number of users and there’s no more time for anything.

Logs have all necessary info the fact that you don’t see it does not mean that it’s not here.

Users can’t attach files here, so you might want to enable that if you want log files to be posted.

It’s enabled what error did you get ? Maybe I missed some file extensions

The logs are not complete but already show a major perf issue. How many songs do you have in Symfonik? And how many songs in the playlist you import ?
It takes like 3 seconds per songs to match when it should take a couple of Ms.

Sorry, new users can not upload attachments.

~350k songs. I usually have above 70 in my playlists but I tested here with an imported playlist of 2 tracks and one created in Jellyfin with 2 tracks. It’s just the m3u8 playlists that don’t work here.

Can’t find the related perm can you give exact error message so I search it?

And can you provide logs of just that part? I’ll check the index perfs with that much songs.

What do you mean specifically? The client pulls in the auto-generated playlist icon but gives me a persistent “importing please wait…” overlay which does not go away until i press anywhere else on the screen. It doesn’t populate the playlists and does not provide any errors. The logs read pretty much as above, unless there’s something else I can provide (which from my end, I don’t think there is)

The importing please wait stays until it’s finished to import, the logs do not have the start so does not contains the answer from Jellyfin so I have no idea what it tries to import, all I see is that it takes 3 seconds per song. So 70 songs would be 3,5 mins I’m guessing you don’t wait that much.

So i’d like the logs with the 2 songs playlist giving the same error starting from before the click on import so I have the full thing. It should take 6 seconds max so it should contains everything quickly.

And found the settings you should now be able to add attachements.

And found the index issue. Now just need proper full logs for the small playlist to see the other issues.

For the record as expected I tried, it worked and I’ve lost 20 minutes for nothing.

Closing this until you can provide the necessary logs.