Hiding a Gonic folder hides Genre data

Issue description:

How to reproduce:

  1. Ensure that all folders of your Gonic server are toggled on.
  2. Go to Library > Genres. Hopefully you’re seeing some genres listed.
  3. Click the toggle/filter button on top right, and deselect any one folder. (All genres vanish).

At first I thought maybe only half of my data had tags, but this behavior happens even if the currently selected folders have genres. Infact…

  1. Toggle on all folders again.
  2. Click on any one genre that you know is only in one of the folders. You’d see something like “1 album - 2 tracks - 7:06”
  3. Click the toggle/filter button on top right, and deselect folders such that you don’t hide the currently listed tracks. The “1 album - 2 tracks - 7:06” text is now gone.


Upload description: prone-to-drift genres issue

Additional information:

 Not provided 

Reproduction steps:

 Not provided 

Media provider:





Yes this is a limitation of Subsonic API there’s no way to easily match genres with libraries.

I guess I’ll add some hacky workaround.

1 Like

@prone-to-drift can you give me an access to your server so I can test the fix?

I’m currently out, but I’ll get home and set up some reverse tunnel for you and send a DM.

1 Like

For lack of a better option, check your reddit messages. I don’t think I can DM you here?

You can chat with me in theory yes, but maybe require an account with more than a day.

And I do not see any PM on reddit.

I didn’t expect you to be online, hah, my bad. I sent the message here before sending there. :person_facepalming: If you are testing, can you see if you can reproduce the playcounts issue as well? Else I’ll try and get logs.

Well no that part is on you, I can’t try random configuration and things to try to repro, multiply that by all the users and there’s no time to do anything.

Thanks, the fix works :slight_smile:

1 Like