Google Pixel 8 Pro - app dies in background

Issue description:


I uploaded some logs just now. My app constantly stopsplaying songs in the background. I have tried all battery settings that I can think of.


Upload description: GreenHammock

Additional information:



Reproduction steps:



Media provider:





All I see in the logs is :

loadError e4.x: Socket closed or retrying [

So seems the OS close network connections to save battery but does not send events telling that the network connectivity have changed :frowning:

You can enable playback cache option to try to workaround that a little, but check the network settings if there’s optimization for battery there too since you are low battery.

Sorry for necroposting, but I am also experiencing a similar issue on my Pixel 8 Pro. What happens on my end is that (for longer tracks usually) I get exactly the same error in the logs.

The behavior of Symfonium in my case is that the current song just stops playing and the app just moves on to the next one in the queue.

I thought this was a configuration error on my end because I hadn’t changed my server’s NGINX default timeout to a high value. I am currently experimenting with playback cache enabled + a long NGINX connection timeout to see if the issue still persists, will make a detailed post about it if it does.

Yup. Error still persists. I can confirm that I also have disabled all the battery saver settings displayed above by @GreenHammock.

It also seems that enabling playback caching somehow made this happen more frequently. Without it enabled it was happening about once a day - with caching enabled it happens in every other song.


Media Provider:

  • epoupon/lms:3.51.0 (docker)

NGINX Config:

server {
    # SSL Config omitted...

    proxy_read_timeout 3600;
    proxy_connect_timeout 3600;
    proxy_send_timeout 3600;

    location /lms/ {
        proxy_set_header X-Forwarded-Host     $host;
        proxy_cookie_path / "/; Secure";
        proxy_pass                            http://localhost:4042/;
        proxy_redirect                        http:// https://;

Open your own issue and check your proxy / LMS logs.

I have the exact same phone, same LMS version and nginx with a simple

location / {
	proxy_pass  https://xxx:yyy/;

And this does not happen :wink:

Your proxy cut the connection: unexpected end of stream yet does not properly close the connection and does not allow the retry.

1 Like