FLAC Playback broken since last update

I have the latest Symfonium running with a Navidrome backend. I have been using it for the past 6 months with no issue, but since the last update (possibly a change within the last 2-3 weeks as I was on holidays) the FLAC playback is broken. They all sound like nightcore music, accelerated but also with a lot of static artefacts. I Have tried with the subsonic app, same backend, and the playback is fine.
MP3 playback is working fine.
I am on WIFI, and i have tried with and without HiRes local renderer.
Any other suggestion? Was there any regressions?
Also when playing said FLAC it seems I cant change the speed, may be the speed is displaying 1x but is actually higher hence why it sounds bad and accelerated?
thanks you

What about the mandatory logs asked in the template you deleted?

If you are in the beta the Changelog have a big line about this :wink:

Enable the option prefer internal decoder and restart the app.

Sorry about that, I thought for this issue logs might not be necessary
You were right I have missed the “prefer internal decoder” that needs to be enabled, it is now working,
thanks you!

When it’s written mandatory there’s no need to think :slight_smile:

And the option needs to be enabled if your device have broken FLAC codecs, but as still no logs I don’t know the device and can’t warn other users :wink:

So can you please provide the asked logs so I have everything needed to automatically enable the option for your device for the other users?

I had this same issue on a Samsung Galaxy tab S8+. I sent some logs in on the issue just now.

Thanks for the logs but that confirm that there’s nothing I can do here your device embed broken FLAC decoder, there’s no other fix than using Symfonium decoder (that’s what the option does).

It’s back to on by default in next release.