Expanded now playing interface button color is dark/not visible

Issue description:

Hi, when playing music the buttons and expanded now playing view change colour automatically which is really cool and beautiful. The thing is for some music where the album art is using dark colours, the expanded player buttons are also dark and become barely visible. There is an option to use the device theme as button color but I would like to have the dynamic theme with maybe a lighter color so that the buttons are visible.


Upload description: AA-debug.log - description

Additional information:

Please ignore my markings in the screenshot below.

The forward and backward along with play/pause and rewind are barely visible in the picture

Reproduction steps:

1.) Play a song with dark background with dark dominant color

Media provider:

Any provider




They are quick visible on my pc and phone, fix your screen :stuck_out_tongue:

Anyway please upload the song that have that image so I can check, when the image is too dark it’s detected, you are probably near the limit.

1 Like

Guess I’m going blind by looking at a screen for 8 hours everyday lol.

Anyways, can I upload the file using the log uploader https://upload.symfonium.app ? Or is it just for logs.

For everything as the doc says :wink:

1 Like

Thanks for the help. I’ve uploaded the song using the uploader and it’s description is “AA-darkimgsong-flac”

Are you sure it’s the same file used? Do you have a folder.jpg in the folder that could be used instead ?

I do not have the same colors extracted at all.

Yes, it’s the same file and I didn’t understand the folder.jpg part.

The album art is not in a separate folder it’s within the FLAC file. I can try that if you want but can you tell me how to do it?

I was asking if you maybe had one file, seems not.

I have no idea where the color is used for you. Have you tried to clear the image cache? Do you use some special settings like hi res images or things like that ?

Yes I have tried clearing the image cache just now, the FLAC file had a 7.82MB album art which I removed and replaced it with 300kb one and cleared the image cache again for that song but didn’t work :slightly_frowning_face:

I just have “Wi-Fi only image downloads” option on, “high quality images” is off. Can the issue be due to how my OS handles colors on Android 12?

Maybe how your phone decode the data then.

And be sure to clear from the advanced settings.

Try to enable hi res images, clear the cache restart the app and see.

Alright, will try and let you know by tomorrow.

Tried all the steps but still doesn’t work :smiling_face_with_tear:. Thanks for your help though!

Edit: I found out that this only happens with like purple to dark purple ish colours I think.