DSP needs to be turned off/on again to work properly with BT headsets

Issue description:

So I wanted to try out the equalizer and found the fancy AutoEQ and it worked great.

Then I disconnected my bluetooth headset, a bit later wanted to play music but it playing in the void. I turned the equalizer off and on again and it worked again.

The system equalizer is turned off.

A reboot of Android brings the issue again.


Upload description: garfieldairlines

Additional information:



Reproduction steps:



Media provider:




Void? I’m wondering if this is similar to what I had reported through BT or the phone speakers.


Only you can tell by trying his workaround;)

Ha, I guess so.

I’ve got a Tasker workaround going now with a one button push, that:
Deletes the Queue
Kills Symfonium
Launches Symfonium
Launches a new smart playlist

I was just kinda curious if he meant by “void”, if it appears to be playing on the Now Playing screen, but has no sound.

Thanks @Tolriq

Ok so let’s be more clear then.

Can you please test his workaround and confirm or not?

This workaround works for me too.

I guess this means this is the direction you’re looking at as the issue?

Well this is a device bug, the EQ is Android lib as the config screen says.

But I can automate the restart of it when the route change so it might actually work as a generic simple workaround.

Appreciate it!

Thanks for all you do!

Sorry @Tolriq your fix is not working…

Then provide new logs and it’s not a fix it’s a workaround for a device bug.

Wait I’m pulling my hair off now, now that I’m trying to rereproduce it it works.

I’ll give you a log when (or if) I manage to reproduce it again. But I’m glad you took the time for it.

Here, I managed to reproduce it. This time on the phone speakers, no Bluetooth device. You got the dump.

The logs are nearly empty, I need more complete logs and repro steps matching the logs to know what you do.

I managed to reproduce it, you got more logs.
Also could narrow it down to AutoEQ specifically, if this could help you. Toggling this off and on resolves it.

Please as asked I need the repro steps, what did you do in those logs (there’s 2 of them).

When does the sound stop, when did you manually restart the EQ, the more precise details the better.

Remember that as it’s a device bug, the logs does not show that there’s no sound or when it happens.

Problem is I am having a hard time to reproduce it… When I can get stable step to step instructions to reproduce the issue I will come back to you.
Sorry it’s quite tricky…

I know but it’s even harder for me :slight_smile:

Ok, maybe I can help you help me…:grinning:

Start Bluetooth play
Disconnect BT (headset back in the case)

Start playback on the phone speaker.

Playing, but nothing, or “into the void”

Disable DSP engine

Play will start
Then you can enable, and it works as it should.

Logs telrod11 uploaded

In the logs the restart of the EQ was done so it seems it’s more complicated that than.

Can you try to do:

Start Bluetooth play
Disconnect BT (headset back in the case)
Disable EQ.
Wait 10 seconds.
Enable EQ.
Press play and report back with corresponding logs if it works or not.

If it requires to restart the EQ after playback is started, then it’s a pain.

This works, no issues, can play on device and then on bluetooth again, no problem (logs « garfieldairlines3 »).