DLNA/UPnP Playback on Yamaha 803d with Jellyfin not working

Issue description:

I have set up a Jellyfin and connected it to Symfonium. Playback on my phone works fine, but when I try to cast it to my Yamaha R803d receiver it does not play the tracks. The metadata flashes shortly on the display but no audio is played.

I have checked the logs too and made sure that the audio url is playable, firefox can play it fine. Additionally, I enabled access logs and saw that my receiver did not made a request to Jellyfin for the audio data, the only requests came from my phone.

I saw an error in the logs “Error/UPnPRenderer: Error getting position info”, but I could not figure out what the actual issue is.

Casting local files from the phone to the receiver work just fine.

Can you see what is wrong? If you need additional information please let me know.



– removed –

Does the domain use https and let’s encrypt?

I can’t access it but most older devices do not support tbe new certs they generate.

I use unencrypted http for now, the TrackURI is also http. Yes you cannot access my services as they are on my private network only.

If I understand the logs correctly my receiver cannot parse or set or get the position info correctly (Error getting position info), it does not get to the point where my receiver makes a request to jellyfin (which I also confirmed with the access logs).

The load work but the play command start fails.

But no proper error returned. Wonder if it’s caused by the proxy are you directly connecting ?
The error is not valid UPnP error.

I made jellyfin directly accessible without the traefik reverse proxy, it also does not work. I tried to use the IP address instead…this worked. It seems like my receiver cannot properly resolve my domain…I guess I have to check this.

Do you know if dlna / upnp should acually work with domains or is it IP only? Thanks!

It can works with DNS but it depends on the devices.

Verify the device configuration of the DNS servers are properly setup. Or your DHCP settings.