Codec filter does not work with Plex provider

Issue description:

I’m trying to make a smart playlist with Codec=FLAC for a Plex provider and it doesn’t match anything. I can make the playlist on the Plex server itself (using Plexamp) and import it in Symfonium which I suppose is the workaround for now, but it would be nice to support “Track Codec” in the Plex provider (which works via the Plexamp app). Not sure whether this is a bug or it should be a feature request.


Upload description: Symtse

Additional information:

 Not provided 

Reproduction steps:

 Not provided 

Media provider:




Hey there! Logs, logs, logs… I feel like I’m in a log-ic loop here! They’re as mandatory as wearing pants to a formal event—awkward without 'em. It’s like the secret ingredient in your favorite recipe; without it, things just don’t taste right. Everywhere you look, from signs to the digital breadcrumbs, they’re screaming, “Logs are a must!” It’s like trying to deny gravity—eventually, things fall apart! So, let’s embrace these logs, the unsung heroes of our tech dilemmas! :star2:

Logs … yes. Should I be concerned about any PII making it into the logs? Can you say more about the security of the logs, will they get deleted promptly? etc

That’s questions you should probably ask yourself before installing the app :wink:

You can read the logs and decide for yourself. The rest is documented.

Uploaded from app. Tagged them with my forum username. One upload for both this issue and my other issue you asked for logs.

Are you sure when you press the 3 dots in the filter it’s empty ? The data is properly sent by Plex.

It shows VORBIS only but I suspect because there are some local files on the device that are VORBIS (no other types on the device in the media library). So I think that’s where it’s getting the types from, not from the Plex server. I have 2 providers in Symfonium: Plex and Local.

But even VORBIS doesn’t work if I select it for Plex, the playlist is always empty no matter what. The Plex server has FLAC, MP3, WMA, VORBIS, … files. I tried various capitalizations, all lower case “flac”, nothing …

If in the playlist I have All providers + Codec=VORBIS I get all local files, none from the Plex server. If I change All to Plex, I get nothing.

I tried enabling “Full sync” for the Plex provider but it doesn’t make a difference.

Ok was able to reproduce, will be fixed for next release.

1 Like