Cannot connect to remote server on non standard https port

client sends a http request to https server

Thank you first:

First of all; congratulations on creating great software. I have exactly 2 paid apps on my phone: Yatse and symfonium. I have used Yatse for music for a long time and, although it’s great, I always thought the general media focus diminished and crowded out the music functionality. I’m very glad that symfonium is now around to focus on music.

The issue

Symfonium (and Yatse) send a http request to my reverse proxy, which will never reach the media server (jellyfin). I think the issue is caused by a non standard https port, although I have never tested it on 443. This means that there is no way for me to access my music server remotely in symfonium. In Yatse, I was able to workaround this by:

  1. Add a connection to the server from inside the LAN over http
  2. save the connection
  3. manage hosts → edit the connection → advanced →
  4. choose connection type: HTTPS
  5. → Basic → change localhost to external url and enter the non-standard reverse proxy port
  6. save and connect!

Relevant part of symfonium log:

2022-04-28 22:04:33.997 Verbose/JellyfinLogger: Caching http://***:pppp/System/Info as http://***:pppp/System/Info
2022-04-28 22:04:34.000 Verbose/JellyfinLogger: --> [270] GET http://***:pppp/System/Info
2022-04-28 22:04:34.007 Verbose/JellyfinLogger: <-- [270] 400 Bad Request http://***:pppp/System/Info (7ms, unknown-length body)
2022-04-28 22:04:34.008 Verbose/JellyfinLogger: <-- [270] Client sent an HTTP request to an HTTPS server.

2022-04-28 22:04:34.008 Error/JellyfinLogger: Request Error: 400 [Client sent an HTTP request to an HTTPS server.
]
2022-04-28 22:04:37.164 Verbose/JellyfinLogger: --> [790] GET http://192.168.2.17:8096/System/Info
2022-04-28 22:04:37.187 Verbose/JellyfinLogger: <-- [790] 200 OK http://192.168.2.17:8096/System/Info (20ms, unknown-length body)

Screenshots:

(A) workaround in Yatse by choosing https from the advanced setting on an establised LAN connection, then editing the server address and port. (B) Could this problem be solved by allowing the user to select the connection type (like advanced edit in Yatse above) when adding the host?

Thanks again for the great app,

CJL

This is fixed in next Symfonium release already. (Not yet backported to Yatse I have a long list but trying to polish here a little more first)

Your server returns a non standard error 400 instead of the normal 426 that would properly switch to https.

Excellent! I look forward to the next release