Basic auth headers not being implemented

Issue description: Basic auth headers not working with Navidrome/Subsonic.

Add as much details as possible, including reproduction steps.

Steps to reproduce:

  1. Setup Apache with basic auth. My reverse proxy asks either for a Client Certificate or Basic auth details.
    Username - myuser Password - mypass
    My device has the client certificate installed under “vpn and apps”.

  2. Enable basic auth headers in Symfonium media provider settings and change the values to myuser and mypass.

  3. What is expected - Symfonium recognises the media provider and is able to play media.

  4. What happens - Symfonium says “Authentication error. Wrong login, password, user or pin code”.

  5. Verified from browser that Navidrome is able to load normally and also that the API status ping returns okay with both basic auth and with client certificate.

  6. Logs show Navidrome gets a 401 from the server. It also shows HTTP failed net.ssl.SSLHandshakeException:

Logs: (2.2 KB)

Join files do not paste the content of the files here! Do not upload them to random website, zip files are allowed.
(They are mandatory, no need to ask if I need them or don’t assume they are not needed for your issue, they are needed.)


Additional information:

Question - What does send default login and password mean? It is under proxy authentication.

Thank you.

You need to add a new provider to ensure proper configuration.

The send default option means that you send the same login/password as subsonic as the authentification. No need to enter them twice if they are the same.

Depending on your configuration you might need to use the v6 beta on Play Store to have the tests to pass.

The logs I sent in the first post were with a new provider on the regular version.

I downloaded the beta now and tried. Still no luck.

The logs for the beta (2.0 KB)

Tried 2 times here. 1st with the default option enabled and then 2nd by entering the basic auth details again.

Thank you for the prompt response.

Information: 5.9.0

This is not logs from the beta version.

Aah okay, Play Store says it’s the beta version though. I’ll wait until the next beta/stable update comes and will check and report then. Can you leave this open until then?

You joined beta but have not updated, Play Store takes some times to actually offer the update. Press check for updates in Play Store.

Works on the beta.
Thanks Tolriq.