Backup giving an error

Issue description:

Error during backup

Read failed: ENOENT (no such file or directory)

I don’t see it everytime, but probably 20% of the time

It’s going to the same dir on internal storage that I’ve used since day 1.


Upload description: telrod11

Additional information:

I reached out to the dev of Solid explorer with logs, and here was his response:


I’ve just checked the Symfonium app and saving the backup works fine. In logs it looks like the file is no longer accessible, perhaps the Symfonium app is killed too soon?


(I’ve tried it with Solid Explorer and Explorer, and both give the same,again not every time, but…)

Here’s a link to a video of the error…


Reproduction steps:

I’m automating the backup with tasker and auto input, and I get the same error (again , not always, but enough that it’s a nuisance.

Media provider:

Local device



The error is not shown by Symfonium, and as you can see the backup is properly generated and once the share sheet is shown it’s out of Symfonium.

The logs does not show anything, so either your phone kill Symfonium or the receiving app bug or does not keep the permission or your phone have an issue, but there’s nothing I can do here.

OK, understood. I’ll play with some more file managers and see if I can get them to handle the handoff better…

So, it is a timing issue as I change directories to save the backup. Is there a “time” set in SF that allows the backup file to expire, or is it available indefinitely after I choose backup?

Just trying to learn how that process works, not saying that anything is wrong at all here…

There’s no time if the client app properly keep the permission and Symfonium is not killed.