Auto refresh server connection after app is opened (like Yatse does)

Hi,

I’ve been using symfonium with loads of joy these past weeks. It even single handedly renewed my intrest in my home server, as the experience is so complete!

Just one issue, my server starts using a Wake-on-LAN when opening a music app. Yatse would auto connect to the server when it came online after a couple seconds, symfonium doesn’t do this. It’ll just keep saying “Nothing to display” until I close the app completely. The sync button in the filter menu doesn’t help either (not that that would be a good solution, as closing the app is way quicker).

How to reproduce:

  1. Disable wifi
  2. Open Yatse/symfonium
  3. Enable wifi
  4. See Yatse auto connect to the server and Symfonium not doing so.

Symfonium would be perfect if this Yatse behavior could be replicated :smiley:

Best regards,
Inse

It already works like that please provide mandatory logs :slight_smile:

Whoops sorry, I sent you the logs via mail :slight_smile:

From the logs all worked correctly Symfonium correctly reconnected and you were able to start a sync meaning you are seen as connected.

Please describe better your issue with screen and what you do / have configured.

Ah yes I see now! It does reconnect but the homepage doesn’t update. Here’s a screengrab to demonstrate what happens: Streamable Video

Hum so I guess you have the only online provider filter enabled? I’ll check that.

Indeed, I use poweramp for local files. Thanks a ton!

May I ask why you still need Poweramp over Symfonium ? :slight_smile:

Nothing against symfonium, but IMHO the poweramp UI, user interaction and animations are just so damn good.

The logical swiping actions as a means to navigate paired to the animations are my favorite.

I also like the clean look of the now playing interface, especially the loudness(?) progress bar.

I also appreciate seeing the file quality at the bottom of the now playing screen, but that’s just a useless wannabe audiophile gimmick :wink:

There’s different now playing screen in settings.

I personally do not find the gesture of PA intuitive but well hard to fight tastes :slight_smile:

For the animations yes it’s currently a missing point from Compose API, they just started to add the base API so pretty in a couple of month I’ll be able to add proper screen transitions, until then I on purpose did not invest time on it.

Anyway please open feature request for each points that would make you switch, maybe at some point you’ll do.

I saw the various now playing designs. I liked the simple ones a lot but switched back to standard as I prefer how the album art doesn’t touch the display border there.

Great news about the animations :slight_smile:

I’ll add the feature requests! Thanks!

Hum I could probably add the picture type as a setting too. Open a feature request for that one too please.