Added music to Jellyfin, but not showing up in Symfonium after sync

Issue description:

I have added a bunch of new music albums to my Jellyfin server and updated the Jellyfin libraries.

The albums show up fine in the Jellyfin app on my phone.

But the new albums do not show up in Symfonium on the same phone. I triggered manually a library sync. One of the new album artists is “Germind” but no albums of him show up in Symfonium.
Expected behavior would be that all newly added albums show up in Symfonium.

What I have tried:

  • Rebooted the phone
  • Several syncs triggered
  • I am checking on page “Library” and made sure that I have selected the correct media source
  • I don’t have a filter enabled that would hide the new albums (I think)

Did I miss anything?



I uploaded a logfile that (hopefully) shows the library sync process with name “vbs_missing_library_items”.

Upload description: vbs_missing_library_items

Additional information:

Latest stable version of Jellyfin running in Docker.

Reproduction steps:

Not sure if reproducible:

  1. Add albums to Jellyfin
  2. Update Jellyfin library
  3. Trigger sync in Symfonium
  4. Check if new albums show up

Media provider:




Your server returns errors during sync so there’s no sync finishing.

2024-03-06 16:25:50.377 Verbose/JellyfinLogger: --> [916] GET https://xxxxx/Users/4743a9871d1f447cb210303e9bd9d493/Items?Recursive=true&IncludeItemTypes=Audio,AudioBook&ParentId=8a05b0252259a1dbd62df97522638439&ExcludeLocationTypes=Virtual&Fields=MediaSources,Genres,SortName,Path,RunTimeTicks,DateCreated,ProductionYear,CommunityRating,UserDataPlayCount,UserDataLastPlayedDate&startIndex=22000&limit=2000&UserId=4743a9871d1f447cb210303e9bd9d493
2024-03-06 16:25:50.612 Verbose/JellyfinLogger: <-- [916] 500  https://xxxxx/Users/4743a9871d1f447cb210303e9bd9d493/Items?Recursive=true&IncludeItemTypes=Audio,AudioBook&ParentId=8a05b0252259a1dbd62df97522638439&ExcludeLocationTypes=Virtual&Fields=MediaSources,Genres,SortName,Path,RunTimeTicks,DateCreated,ProductionYear,CommunityRating,UserDataPlayCount,UserDataLastPlayedDate&startIndex=22000&limit=2000&UserId=4743a9871d1f447cb210303e9bd9d493 (1215ms, unknown-length body)
2024-03-06 16:25:50.619 Verbose/JellyfinLogger: <-- [916] Error processing request.

Check Jellyfin logs to see why they fail.

Okay thanks alot for quick response. I will investigate

The Jellyfin Sqlite database seems to be corrupted:

[22:09:31] [ERR] [53] Jellyfin.Server.Middleware.ExceptionMiddleware: Error processing request. URL GET /Users/4743a9871d1f447cb210303e9bd9d493/Items.
Corrupt: SQLitePCL.pretty.SQLiteException: database disk image is malformed
   at SQLitePCL.pretty.SQLiteException.Throw(Int32 rc, Int32 extended, String msg)
   at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc)
   at SQLitePCL.pretty.StatementImpl.MoveNext()
   at Emby.Server.Implementations.Data.SqliteExtensions.ExecuteQuery(IStatement statement)+MoveNext()
   at Emby.Server.Implementations.Data.SqliteUserDataRepository.GetUserData(Int64 userId, String key)
   at Emby.Server.Implementations.Library.UserDataManager.GetUserDataInternal(Int64 internalUserId, List`1 keys)
   at System.Collections.Concurrent.ConcurrentDictionary`2.GetOrAdd(TKey key, Func`2 valueFactory)
   at Emby.Server.Implementations.Library.UserDataManager.GetUserDataDto(BaseItem item, User user)

I have hopefully repaired the DB by dumping it to a sql file like this and then rebuilding it from that file again:

sqlite3 library.db .recover >data.sql
sqlite3 library.db <data.sql

And it works now and I could successfully sync with Symfonium! But I am not quite sure if the DB content is really ok now. Let’s see…