Small "disconnect" between tracks


Symfonium is really promising but I am facing an issue and I would like to know if I am the only one with this.

The app is installed on a Xiaomi Pad 5.
It runs the latest MIUI and MIUI “optimizations” have been disabled.
I also took the precaution of turning off “Battery restriction in background”.

The Pad 5 is connected to Internet with an USB-C => Ethernet adapter.

The music is retrieved from an Emby server located on a Terramaster NAS and is sent to a Raspberry Pi4 running moOde.

The music is then sent to a DAC that display the sampling rate of the signal received.

But each time I change tracks, there seems to be like a “disconnection” which produces a slight “pop” in my headphones.
And when that happens, if I look at the DAC’s display, for a short time (less than an second) it shows that it’s getting no signal.

Is this normal ? I think I did not got this in the previous versions of Symfonium…

Thanks for your answers.


As the deleted template says I need logs :slight_smile:

But if you are casting to UPnP then yes there’s no support for Gapless yet as it’s broken on most servers. So there can be a small delay between tracks.

BTW for the other who read this, since none of my UPnP device / software anyone knows an UPnP server that properly support that and run in VM / Docker so I can test any future implementation.

Not sure this is the answer you’re expecting.
But I use Emby server on the NAS.
I cast music to my Raspberry Pi4 from the Emby serveer on the NAS via UPnP.

When I use another software as yours (am I allowed to name it ?) I have an option to select “Gapless” and it works flawlessly.

But even when this is not selected, I have a small delay between tracks but NOT this “disconnection” where, for a brief moment the DAC doesn’t receive any signal anymore :frowning:

I’ll send logs later. Not really at home at the moment…

There’s many different parts here :slight_smile:

About the other app you are probably talking about bubble that have different functionality :wink:

Anyway so yes as explained Symfonium does not yet have gapless for UPnP it’s planned for next release.

But the apps do not talk to your DAC directly we send upnp commands to moode that then talk to your DAC. Symfonium does nothing special and just send normal play commands, the disconnect are triggered by moode and you’ll need to see with them how to gather logs and what is causing this so I can eventually find a workaround.

Thanks a lot for your answer…
For me the problem solved itself quite easily.
I simply cannot connect to the emby server that is located on QNAP NAS.
The server appears in Media Servers.
But it keeps rejecting login/password I enter even though I quadruple checked them and they are correct :frowning:
Other competitor apps can log in with absolutely no problems :frowning:
So, at the moment, Symfonium cannot be used anymore at all…

Well 8 days asking for logs and still no logs provided despite them being mandatory.

So thanks for all the comments but I can’t do anything for you since you do not give the small necessary things for me to help…

So not sure what you expect, but I hope you are feeling better :slight_smile:

Log sent via e-mail a minute or two ago.

I think the problem is because I located the emby server on a QNAP Nas.
This requires emby to be installed manually (unlike on old NAS where there was a bult-in emby App).

Just to mention I tried the log/password used to connect into emby.
I also tried with no password (as I configured emby not to ask for password when logging in from LAN).
And I also tried with the login and password used to connect to the NAS itself.

I also tried to delete all data from the Symfonium app.

No changes :frowning:

BUT it seems the problem is with the Pad 5 from Xiaomi. I can connect from my Xiaomi phone with custom ROM. So maybre a problem with MIUI ?

Caused by: android.system.ErrnoException: connect failed: EACCES (Permission denied)

Your device prevent network access to the application.

Check your OS settings, eventual firewall or anything that messes up with the basics of Android.

Many many thanks for your support…
In indeed notiec thant on my phone I have the ability to allow access to network to Symfonium.
This possibility does not show up in MIUI :frowning:
I’ll try to sort it out and report if I manage to do it and what I did to solve the problem on MIUI.


OK. Problem solved : uninstalled Symfonium and reinstalled it and now ot connects.

Weird thing is : it reported to have full acces to network before I uninstalled it.
So the culprit is probably that stupid MIUI that I more and more begin to dislike…