Navidrome - Unable to get media provider version

Attempting to connect to a new Navidrome server. I’m going in under Subsonic as a media provider.

I’ve tried using the local domain, external domain, http://ipaddress:port, http://ipaddress and filling in the port field, ipaddress:port and ipaddress while filling in the port field.

I created a test user in navidrome with username: test, password: test just in case it was an issue with special chars in the password field.

I’ve tried toggling Legacy authentication and Compatibility mode.

I get the following error message regardless of how I attempt to configure.

Unable to get media provider version. Check the port value and that this port is not used by another software on the media provider. Press Help button for information about configuring your media provider.

Is there a step I’m missing?
EDIT: Navidrome is running in a docker container if that matters.
Navidrome version 0.49.3
Symfonium version 4.0.1 (886)

You are missing the mandatory template that you deleted that explained that logs are mandatory and how to gather them :slight_smile:

debug.log (7.4 KB)

Your proxy configuration is wrong or what you enter is wrong :slight_smile:

You enter http://navidrome.local/ as the link to Navidrome but there’s a redir to http://navidrome.local/music/app/ (But not properly redirecting the rest).

So my guess would be that you need to enter http://navidrome.local/music/app/ in Symfonium since that would be the proper url of Navidrome.

That returns the same error. As does http://XX.XX.X.X:4533/music/app/
I think this may have something to do with Navidrome. I quickly setup a Gonic container, which is another subsonic api server, and it connected right away. I’m going to try to setup an LXC container and run Navidrome natively instead of in Docker and see if it’ll connect that way.

Not Navidrome but your docker / proxy the /music/app stuff is not from Navidrome but a layer above.

I found the issue.

Configuration Options | Navidrome

When a BaseURL is configured for use behind a proxy, the app will not connect. Removing the BaseURL allows it to connect. This is with docker as well as with a bare linux install. This is why you’re seeing /music/app in the logs because /music was the BaseURL I set.

I think you need the base url to match the proxy value not just out a value because you are behind a proxy.

Ping @deluan

Looks like your BaseURL is /music, right? Then in Symfonium you need to enter http://navidrome.local/music. The /app is the path for Navidrome’s Web UI, added by Navidrome itself.