Missing album art in Motorola Active Display

Issue description:

While album art does show in app and in the notification shade, it doesn’t show up in Motorola’s Active Display, their ambient display equivalent.

“Disable media session” is not enabled.


debug.log (146.0 KB)


Additional information:

  • Symphonium 4.0.0B1 (863) [also present in 3.2.0]
  • motorola edge 30 pro, Android 12

I don’t have control over this.

From a quick search it seems that many apps are broken after an update of that app and downgrading might help.

There’s no API or doc I could find about it.

That’s a shame, I figured this would be a tough one.
I tried snooping around in logcat for any hints but I got nothing.
Perhaps the album art metadata is not getting added properly to the media session? Most other media apps work just fine. I’m not sure what moto display uses, if it’s either the URI or Bitmap version, or if it uses the “key art” version or not.

It’s properly set for everything that is documented :slight_smile: Auto, wear, Android 13, all the media session test tools everything shows the art as wanted.

I guess they want an uri and that since it’s an OS app it will have the permission when playing from media store, but it could break other apps …

I can try to push an uri for the image I cache but that app should be fixed :slight_smile:

It wouldn’t be the first time a feature on a Motorola phone is a little buggy :upside_down_face:

So that’s a no go due to the potential for breakage? I’d gladly try a test build with an URI push.

I will but I can’t cover all cases to not break other apps. This is absurd.

Unfortunately, that has not fixed it.

Of note, the open source Finamp player does display album art, perhaps it would be worth looking into how they’re doing it?
Failing that, I’d just hope and pray the upcoming Android 13 update fixes this :woman_facepalming:

Without the device to repro it’s impossible to know. Could just be that the image I set is too high quality and it can’t handle it. Or nearly anything.
Since everything works everywhere else, I can’t just guess here. Their support could maybe help.