EQ not auto switching up on device pairing

Issue description:

EQ is not auto switching when I pair devices.

Logs:

Upload description: Dhuff2037

Additional information:

 

 

Reproduction steps:

 

 

Media provider:

Plex

Screenshots:

     

I hope you did not break something by typing such a long and precise description :slight_smile:

The logs are empty, you need to reproduce the issue in the logs so I can see anything.

What more did I need to say other than the auto EQ is not switching when devices are paired?

The configuration you did in the app, screenshots and as said proper logs showing the issue so with actual pairing change to see what is happening.

Your logs contains 0 second you just enabled then disabled it.

There is my configuration for the EQ. I just resubmitted logs. I think in the correct way. I enabled debug mode, had nothing paired with my phone, paired my earbuds, EQ did not change, I submitted logs.

Hum the logs does not show the change detected by the OS that’s strange.

But in that screen you are already loaded with the correct profile, so nothing will change you need to create another phone profile with another EQ setting.

Before I enabled debug mode I switched to the EQ profile I use in my truck and then entered debug mode and then paired my earbuds and it didn’t change. I just sent that screenshot of the EQ profile to show how it is saved.

Hum the app does not receive the events from the OS.

Can you confirm that in the notification of Symfonium it shows the device it’s connected to ?

Just in case can you try to enable the BT permission too?

I’d need new logs with cold app start. So enable logs, force kill the app (not just swipe force kill) then start the app and connect a BT device.
Maybe it will show an error when the app tries to register for the events.

Okay logs sent again. I enabled my truck eq, then force quit the app. Opened the app, then paired Bluetooth earbuds. Mini player in notification screen shows the buds are paired. EQ stays on truck and does not change.

Ok so this time the logs shows all.

Selected route David's Buds2 Pro

The name that the OS return is “David’s Buds2 Pro” but your profile is tied to the name “Galaxy Buds2 Pro” so they do not match.

Can you check in the device list that there’s not the proper name present there and you maybe renamed the device and selected the wrong one ?

Hey that seems to have fixed it. There was indeed another device labeled differently in the device list. Thanks for your help and your time.