Do not seperate port in url, url path support

Hi,

When I was inputting the server address, the app requests me to put the IP or address in the first block and the port in another block.
Usually, this works fine. But it prevents me to add a server whose url contains “path”

for example, 127.0.0.1:8888/subsonic

It does not, you can enter the full url and it will work too. you can enter 127.0.0.1/subsonic and the port in the port field too and it will work also.
You can use nearly all possible variation and the app will try to figure out what you try to enter.

I just tried and both failed.

If I enter the full url and leave the port field blank, an error message under the port field pop up and prevent me to finish.
“incorrect value: please set a correct port value”

If I enter 127.0.0.1/subsonic and the port in the port field. It failed to connect.

You need to enter the protocol http or https:// depending on your need.

Either you enter a proper url or you split the data.

For the second case I’d need logs.

http://127.0.0.1:8888/subsonic
(blank)

“incorrect value: please set a correct port value”

http://127.0.0.1/subsonic
8888

“error resolving hostname/ip: check the entered value.”

Provide the asked logs …

I don’t know what actually happened but looks like it has been solved now.

I tried multiple times for both two methods and w/ w/o http://. And it never passed. I am sure there is no typo,
Then I reinstall the app and enabled debug mode. I tried to reproduce the error, but this time both methods worked.

The two apps should be the same release as they are both installed today…

Thank you for your assistance!

Without logs we’ll never know. But it works that’s what matters.

yes, I tried to reproduce the error with a clean install and then upload the log, but it just gone…

While I still think the port field is not necessary

Well I do publish apps on Play Store since 10 years now, all with user having to configure their media center information, and while I know you think you know, you don’t know how all the other people think.

This way of configuring is the result of thousands users feedback.

different people have different ideas. that’s true and normal and I totally accept it as long as it works.

I think I figured out what really happened.

If you are adding a new remote, you can enter the full url like “http://0.0.0.0:12345/remote”, and leave the port area blank. Everything works fine
But if you are editing an existed remote, trying to do something above will give error.

Also, based on the current mechanism, after you add a remote, the BaseUrl will be hidden.
e. g., you add “http://0.0.0.0:12345/remote”. When you try to edit the remote, you will only see url “0.0.0.0” and port “12345”.

One more suggestion but not related to this issue.
I suggest allowing set the display name when adding a new remote. Currently, I need to add a new remote and click on it and edit the display name.